NanoKontrol 2 and CC 11

Just updated to Cubase 12 Pro. My NanoKontrol 2 is recognized in Cubase, but for some reason the fader that controls Expression as CC 11 is transmitting data as CC 0. This is an included script with Cubase. How can I change the CC data from 0 to 11? All other faders , knobs, and buttons are correct. Just the CC 11 fader isn’t correct. Thanks!


The script expects some settings to be working. So it sends SysEx data when it starts, to set the nanoKontrol. If you don’t want to use the script, just disable it, please.

Thanks for the reply. According to the Cubase manual, one cannot edit a ready-to-use script. Or at least I haven’t found a way to do this. I don’t know how to disable CC 0 and add CC 11 to this first fader. That’s what I’m seeking help to do. Thanks!


You can overwrite the factory scripts. Copy the script to the Local folder. Then you can change it.

Thanks for the help so far. How do I open the script to change the setting?


You can use any textEditor or in better case any coding-editor. It’s a JavaScript file.


Just as a follow-up: I disabled the included Steinberg script and set up a new script and all is well. I did notice when setting up the new script that the first fader (which controls Expression) is default set to CC 0. I wonder if this is the case in the Steinberg script? Anyway, if you have the same problem with the Steinberg script, just disable the script, then create a new one.


Steinberg is using the factory settings of nanoKontrl 2. You probably custom this settings in the past.