Native instruments mk3 midi mode - no sound

I got me a NI maschine mk3 witch i want to use in midi mode
It should be possible to use it as any other keyboard but instead of keys, i have pads should it?
I know how to turn the maschine in midi mode and in Cubase pro 12 ( w10) i can see it has input but no output. When add a track- instrument-kontakt and click on drums. And for midi “all midi inputs” my keyboard works fine, but the maschine has no sound. I have no clue how to solve this problem…

The MK3 in Midi Mode should work Just fine as a drum pad controller (as well as a Midi Remote Controller". You should see an input and output port in “Midi port setup” in the Studio Setup Dialog. The Right screen of the notes assigned to the pads should be displayed. Drums start at C1, so press a group button until the first (bottom left pad) says C1. If you do not see notes displayed, then you need to set up a template using Controller Editor that is used to set up the pads etc.

here is a vid on setting up Midi Remote which also allows you to use the MK# as a playable controller. Jef has a bunch of vids on using Maschine with Cubase, I would check those out.

Thanks Blindeddie but it doesnt work for me
The input and output port in “Midi port setup” are not named in- or output but
Maschine MK3 ctrl MIDI and Maschine MK3 EXT Midi- both marked as active
The manual says to use the build in audio interface, and the software installation did set the Mashine mk3 as "Main MK3 WDM Audio"but I want to use my RME Fireface Audio interface instead, so I did set that interface back as my main again. at the beginning of Jeff Gibons explannation he already has a sound in Cubase, so for my problem he starts to late, I don’t have sound from the beginning … Perhaps I made a mistake somewhere but I dont know were …
I am an old guy so perhaps not the smartest with software so excuse me for beiing a bit dumb. But I do I need midi cables ( i didn’t ) I only use a usb connection.
Its also possile I made some msiatkes within the Maschine 2 software.
Dont know what to shoose within the “Master - group and sound settings”

When using not in midi mode I also have problems. _ There seems to be no input signal only a output in Cubase
in machine 2 the audio routings are : Audio : Interface driver = ASIO / Device = ASIO Fireface USB / Status = running / sample rate = 44.100

input machine 2 = port analog 1 ( L) input machine 2 = port analog 2 ( R)

MIDI : input = Maschine Mk3 Ext mid - Maschine Mk3 Cntrl mid - UCX Midiport 1 and UCX midiport 2

MIDI Outputs = Maschine Mk3 Ext mid - Maschine Mk3 Cntrl mid - UCX Midiport 1 and UCX midiport 2


In Cubase : Studio setup : midiport setup: Windows MIDI - I/O in = Machine MK3 Ctrl MIDI = active

Windows MIDI in= Machine MK3 EXT MIDI= Active

UCX Midiport 1 in = UCX Midi port 1 = active

UCX Midiport 2 in = UCX Midiport 2 + active

midi out : all the same as midi in

----------------------------------- PS : when I select only in and outputs RME UCX Midiports in Normal mode , I only have a output signal in Cubase

when I select only in and outputs RME UCX Midiports in Midi mode, I only have a input signal in Cubase

Well Jef has another video that explains how to setup and use Maschine in Cubase.

To use Maschine, you do not need Midi Cables it uses the MK3 Ctrl input and Output.

I will admit, your problem is slightly confusing as you are explaining a bunch of issues all jumbled into one. Are you adding Maschine to Cubase as an “Insturment”? Are you talking about Maschine “Standalone”? If you can break things down it would be much easier to answer.

Like, do you get sound out of Cubase using the RME interface playing Audio or VI?

and since you are confused by Maschine, NI just put out this Video…

Cubase is working perfectly. no problems at all.
The only problem is seting up the maschine. Evereything else is still working perfect.
The first problem started after installing the maschine software and i didn’t have any sound anymore. This whas hapening because the installation of the maschine changed the main audio from the RME audio interface to the build in audio interface of the maschine.
When following setup info on the internet I notice a lot info who give they advice to install it that way? I think there are a lot of people that want to keep there own audio interface as the main interface, and not the inner maschine interface.
And thanks for the second Jeff Gibbons link, but again on this video, he starts with adding a track- choosing Machine 2 and starts to play. I don’t get this far
because I have no sound at that point. So he starts again without the setup problem that I have. He is not showing the very first installation of the Machine software

In order to figure out what is going on, you would need to list the steps you are doing.

Are you able to get Maschine working outside of Cubase? (Standalone mode, not as a VST).

That would be the place to start by getting an understanding of Maschine before you integrate it into Cubase.

Perhaps you need to set the audio device in Studio Setup/Audio System within Cubase to be the Maschine hardware, is that the problem ?

Audio has nothing to do with the MIDI port setup.

Yes, its working allright without cubase. But no sound in Cubase wile everything else works perfect
in cubase, I can record and playback without any problems using a keyboard in Cubase.

Ok, then probably a routing issue. There is a post in the old NI forum that has a step by step explanation… I have to dig up the link and will post it when I find it!!!

OK, here is the link to the Old NI Forum post I mentioned. Hope it helps…

[Guide] - Cubase + Maschine MIDI Routing & Integration | NI Community Forum (native-instruments.com)

Also, if you can upload a copy of a Cubase Project with Maschine in it that “Does not work”, I can try opening it here as I cannot replicate your issue. I add an Instrument track, select Maschine, load a Kit or Instrument in Maschine and everything works fine.

1 Like

Thank you for your time and effort, I really appreciate it.
I’m not good with computers but that should be clear by now…
The only reason I bought the Maschine was because I’d rather tap the drums on pads than on my weighted keyboard.
I thought it would give some comfort but so far I’m mostly experiencing frustration, probably due to my own shortcomings. Do you mind if I start at the very front and try to solve my problems one by one? First of all : What do I check in preferences in the machine 2 software please?
Because I want to use my own audio interface, I checked midi in and midi out : UCX midiport 1. Is it the intention that I also tick “Maschine mk3 ext midi” and/or "Maschine mk3 Ctrl midi "?
There are no more optically visible machines than those mentioned

I got it working in cubase with Groove agent se.
Didn’t change much- in machine 2/ preferences / I checked : UCX midiport 1 and port 2 and I
also checked Maschine mk3 Ctrl midi. I did the same in Cubase /studio setup/midiport setup
.
Added a instrument track / Groove agent se — all midi inputs . So far its working this way in midimode. A bit strange to me ( but for me not very importend) is the fact that the machine mk3 only starts up after the usb input after starting my pc? And another thing ; I sometimes have to start up the mk3 two times, before i get te posibility to put it in mid mode with the Shift+ Channel midi buttons ( maybe i’am making a mistake there in startup order or something?
For now, my smile is comming back -Gonna practice some for now

Thanks very much BlindEddie for the answers and your help! My Maschine is working now the way I hoped it would. Also in midimode with kontakt . The correct MIDI port of the MK3 whas Maschine MK3 Ctrl MIDI. The other ones I have checked are the UCX Midi port 1 and 2 ( My main audio interface ) I did the same in Cubase studio settings.
The links where also a great help!

Glad to hear you are up and Running!!!

1 Like