Navigate left/right via Generic Remote (solved)

Has anyone figured out how to map “Navigate left and right” to a generic controller? No matter what I try, I can’t get my TouchOSC (via generic remote) to change the selected channel in the mixer (like what the left/right arrow keys do).

Are your midis setup right in the midi setup ?..
devices menu/setup/midi port

i use automap pro, here you dont need to setup a generic controller,
you setup in automap, hence the controller is not setup to send midi
nor is cubase setup to recieve midi from this controller.
it sends key commands… basically cubase thinks its the computer keys that are talking
not a midi message from a midi controller.
This also leaves your midi data buss in & out less congested…
So am sorry I cannot help but wanted to share this information.
I use the launchpad so thats 64 key commands at hand & another 64 by turning the
page so to speak. Fantastic workflow !
I did try initially with the generic setup but was experiencing the setup to re-patch
commands unknown to me so I tried the above & all is really sweet.
I could be wrong but I think the generic setup is more for midi & controllers … i.e.
controlling synths, the mixer etc… but not so good with key commands …
Only My thoughts & also obviously only regarding My current Computer & App setup/version.
It works…

Good luck

What does your reply have to do with my post ?

beatpete …
I didn’t mean to go off topic or whatever I did.
I was just trying to help …
I hope you can sort it.


Jb figure this out (I never would have).
from a another thread:

“you need: VST mixer/device/selected, but to get there you first select: VSTmixer/Selected/selected, and then change the first “selected” into “device”. If you assign a cc and a fader in touchosc to that you can scroll trough the channels (128 max). to create buttons that go one channel up or down use: command/navigate/up or down,and assign a cc or note”

old thread,

but thanks anyway for the last post :bulb:

i have a different question regarding touch osc,
how can i setup “auto select” fader in touchosc or cubase ?

i mean that when i touch a fader on my touchosc template
that it automatically selects the same fader in cubase ?

I don’t think you can avoid that with the generic remote but I believe you can disable it with a mackie control template (I use both with Lemur).

@ steffenb:

You could use the controller mentioned above, since the above setup creates a cc that can select 128 different channels;

Ad a parameter in touchosc “on touch” (z) for each fader, using the mentioned setup with a different value for each fader/channel (for fader 1: cc as mentioned above, value 0 selects Channel 1 by touching fader 1, for fader 2: same cc, value 1= Selects channel 2, and so on)

I am almost exactly in the situation as the first post writer, except not with touchosc but on a midi keyboard (Keystation 88).
I want to assign a midi cc number (pressing 1-1 button on the controller) to the left and right arrow keys, to change (step) between the mixer channel strips. In Generic Remote settings, I have tried everything, but it is not working. Obviously, I setup Command - Navigate - Left/Right. Not works. Tried what mentioned above that “trick” :
“you need: VST mixer/device/selected, but to get there you first select: VSTmixer/Selected/selected, and then change the first “selected” into “device”.”
no success.

Actually, the function is working, because I can navigate (selection moves) between the parts when I am in the project area, but not in the mixer.
What is wrong, why not working with midi CC these commands with the channels?