Need advice on combining 44.1 and 48 files

Cubase is not very forgiving if you get the same rate wrong. For example, if the project is set to 44.1 and you drag in a 48K WAV, it will sound slower and lower. Worse than that, there is no warning that the rates don’t match. other DAWs wither pop up a warning, offering to change project settings, or they might automatically convert the file.
All my field recorders are set to 48K. This is usually a nuisance when I forget to set my Cubase project to 48K. Am I missing something? Is there an option to at least get a warning?
My bigger question is what happens if I must work with a combination of WAVs, some at 44.1 and some at 48? I guess I could manually stretch them to all sound right, but that would be a drag.
I have the feeling that I am missing something really simple here.

https://steinberg.help/cubase_pro/v11/en/cubase_nuendo/topics/importing_audio_and_midi/importing_audio_and_midi_on_import_audio_files_settings_r.html?hl=sample%2Crate

Thank you. I have seen that option before, but I guess it never occurred to me it would apply to the sample rate. I mean, what sense would it make to EVER intentionally import a file at the wrong rate?

I guess I was expecting Cubase to pop up a dialog saying “Hey Dummy, you are tying to bring in a 48K file and your project is set to 44.1. What do you want me to do?”

And am I correct in assuming that there is no way for Cubase to handle the file unless you select the option to copy audio to the project file? I would have thought it possible for Cubase to convert the file on the fly and not permanently save both copies.