Need help with MIDI keyboard

Hello everyone,

I’m new here to the Steinberg forums and to the world of music recording/editing/producing and need help. I’ve installed Cubase Student 6 (which as I understand it is the same as artist 6) on my 32-bit Windows 7 PC and I have an M-Audio Oxygen 25 MIDI keyboard,with the appropriate drivers, plugged into it. The problem is that I can’t get any sound from the keyboard while in Cubase. The keyboard is set up fine and works in a program called MIDI-OX but when in Cubase there is no sound produced even though the program receives signal from the keyboard. I can record a track but on the playback there is, once again, no sound. I’ve also imported a MIDI tune that was already in windows to Cubase and that played back fine. Now I’m at a loss, Cubase works fine on its own and the keyboard works fine on its own but somehow when put together they won’t work their magic.

Anyone have any advice on what to try next?

Thank you

Did you select in “Devices” your soundcard?
In “VST connections”: is your routing setup correct?

So you can succesfully record MIDI notes from the Axiom onto a MIDI track or Instrument track?
But you can’t hear yourself play or hear any sound from the VSTi? Please explain the setup a little better. MIDI track to VSTi in the instrument rack or Instrument track? If the former,check the input and output routings to make sure the MIDI track is being sent to the VSTi. If you want to hear yourself play live, you need to enable “Monitor”. Which instrument are you using? If its in the instrument rack, are the outputs enabled? Are the MIDI channels between the track and VSTi the same? It these ideas don’t help, post some screenshots so we can see how it is setup.

I’ve checked the VST connections and it says the output are the speakers, however the input is from two microphones I wasn’t even aware I had on this computer. There is a constant audio activity from these that lead me to believe they are inside my computer tower. Another thing I’ve noticed is that once Cubase is open sound is cut for everything else and any .mp3 or YouTube video is soundless.

Jaslan, I don’t think I’m savvy enough with this program to give you the kind of info you’re looking for so I’ve taken screenshots and pasted the three of them in a word document here attached. I hope it helps and please tell me if you need more or better quality ones (these are a little hard to read you may have to zoom)

Thanks to both of you

cubase screenshots.doc (1.33 MB)

In order to stop the microphone inputs, go to the VST Connections, click on “Microphone (high definition 1)” and select “not connected”. You can also delete the input bus altogether if your like.

For the sound, You have the output of the MIDI 01 track going back to the Oxygen controller. You want this to go to the instrument. If you don’t already have an instrument in the instrument rack, select f11 and open an instrument there. Then go back to the MIDI 01 track and select that instrument for the output of the MIDI track. You also have the MIDI 01 track muted. Hope this helps!
I see you have also created an instrument track with Groove Agent one. I recommend creating another instrument track with Halion Sonic SE or Prologue. Instrument tracks are a little easier than MIDI tracks to the instrument RACK.
One last thing. Unless you want to hear yourself play live or record, turn off the record and monitor (red and yellow buttons that you have on in the track list).
Oh yeah. The output setup in VST connections looks good too. Lastly, don’t worry about it now but once you get a little more comfortable with everything, consider downloading ASIO4ALL free from the internet (google it). It is a better ASIO driver for generic soundcards.

Alright I’ve got it working, the key was to remove the mic inputs. Thanks for all the help it’s truly appreciated!

Thanks again,