Need some help (can't find my Halion 5 box to install)


I need some help. I already emailed Steinberg Support. Waiting for reply.

Meanwhile, as I wait for a reply, I thought it might be possible to get some feedback by posting this here, just in case someone on the forum knows how to sort this out.

Basically, I’m setting up a new PC-System, with Cubase 7.5, Halion 5 was installed on my old PC-System, But… unfortunately, I can’t find my Halion 5 product box to install it on the new PC-System. So basically I lost the Halion 5 box, and since it has the installer, and content DVDs. I’m not able to install it.

I have the Halion 5 License registered on my eLicenser.

Since there is no way to install Halion 5 as a download, although, I see only halion 5 updates for download.

So…How can I install Halion 5 on my new PC-System, given that I lost my Halion 5 product box ?

Any feedback /support on how to resolve this issue would be very helpful.


just ask to Steinberg the link to HALion 5 ISO (2x DVD)

Hi Home Studio 87,

Thanks for the feedback/help.

Since I emailed Steinberg Support, Maybe that’s what they will actually do to enable me to install the Halion 5 application, and the 2 X DVD content.

I wonder why they don’t have it on their FTP site ? it would be so useful to have these download links permanently available on their FTP Site for download, since they won’t be of much value unless one has a a registered license on their elicenser.


kind regards,

Hi roel,

*** Awesome ! ***

Many Thanks for the download links. I had no idea these links existed :slight_smile:


Hi Roel.

Have you actually tried the above links?
When I try them, the download starts fine. But when the files reach 2.097GB, they stops, just like they´ve finished downloading, (and ofcouse the ISO files are broken).
I know it cant be my computers. I tried on 2 different, and both had no problems downloading a full 9.1GB archive of Cubase pro 8. But these HALions links are giving me problems.

Hmm, just tried to download from my work (that means 3. computer), and now it seems to work. At least it has reached 2.6GB as I write of the ISO 2.
I really wonder why it didn´t work the other day I tried from two different computers and infact two different locations as well.