Need some help with PC

Long story short: I did a remodel in my studio that was supposed to take 2 weeks. We are finishing at week 12!!! :angry: The PC has been off almost the entire time. I just fired it up to test the new displays a week ago and made a scratch recording on Thursday. Windows 10 did some kind of critical upgrade overnight and as of yesterday I have several problems.

  1. Me elicense has deactivated one of my programs, BUT WON’T TELL ME WHICH ONE! It’s just giving me a serial number to track down. The Nuendo license and my EWQL license all seem to be working fine. But when I launch Nuendo, it tells me that I don’t have enough permissions to work properly.

  2. I can’t double click on ANYTHING to get it to open. I have to right click on everything too open the menu to tell it to open (very annoying!),

  3. System Restore won’t offer me a date before the, so called, critical Win-10 update that took place Thursday night. So, no option of normal recovery there.

  4. I’ve gone from a 12 fader Artist Series setup to a 20 fader setup by adding a second Mix. But I can only get any 3 of the 4 devices to work. So, I can get both Mix & Control to work, but not the Transport or I can get the Transport to work with a single Mix & Control. I have purchased a new TP Link 16 port network switch, hoping that will solve the problem. But, right now, I’m more concerned about the 1st three problems mentioned.

  5. Has anybody here ever had to deal with something like this? How do I get my PC back to normal? Thanks!

The new switch care of the Artist Series problem. All 4 devices work now. But I’ve noticed that I’ve lost my Favorite Plug-in Collection in the inserts menu.

I still can’t double click on anything to open it. Every VSTi I open gives me that same elicense error message about not having enough permissions to run properly. But then they essentially work fine. I tried loading the serial number into the cortana search engine. But, of course, it turned up nothing! It couldn’t find anything if you pointed right to it! Whatever they changed from Windows 7 search engine was a major loss!

I can’t think of anything else to try. ANY SUGGESTIONS AT THIS POINT WOULD BE GREATLY APPRECIATED. I’m scared to start a real project with it working like this and I’ve already lost a ridiculous amount of time with the remodel. So if you guys have any idea wht this issue is, PLEASE speak up!

I had a few issues myself with the win 10 upgrade but most were solved by updating my elicenser software but you have a whole bunch of stuff I don’t so maybe a trawl through driver sites and maybe a few other forums?

Yeah, I did a remote session with ADK to get the license issue resolved. Now (as we speak) we’re trouble shooting apps which are stopping the double click function. THEY can double click on my folders and get them to open. I can’t! We turned off a bunch of stuff and rebooted the PC. For a while I had my double click function back. But when we reinstated Eucon 3.6, no double click function! So, right now, that LOOKS like it may be the culprit. I’m backing up the OS now and then updating to Eucon 3.6.1 to see if that stops the compatibility issue. What a pain!

Looks like it was EUCON 3.6. I uninstalled it & replaced it with 3.6.1 & everything appears to back to normal.

Keyplayer, it’s good to hear you’re up and running again.
AVID software can be such a pain. I once had PT HD refusing to launch when a Razer mouse was connected to the system…