Need technical help for Spitfire products (BBC or others) in playback in Dorico.

Need technical help for Spitfire products (BBC or others) in playback in Dorico.

Example:

I am in Dorico Pro.
BBC Pro Orchestra.
Violins part.

I imported the Cubase map expression created by Babylonwaves and use UACC KS.

The first notes have no accent or legato, nor specific techniques. They must play by default, that is to say the “long” joint.

Should we write on the score: long (or nat.)? And rewrite that every time we go back to the default joint?

I’m looking for a way to avoid this, ie to indicate that with no further articulation, Dorico should send the request to play the default Articulation, ie “long”.

Sorry for my bad English (I translate by Google).

I’m answering myself.

I think Dorico’s new Template for BBC corrects all of this. It is better than the work of Babylonwaves. I’m continuing the test, but it’s promising.

Yes, I would suggest you start from the playback templates you can download from the Dorico blog.

and then your biggest decision will probably be whether to use “legato” or “long” as default in the strings. It makes a big difference but will depend largely on whether you need the more responsive faster articulations of the legato patch (as I do) or want a smoother approach which might work well for some film or mood music using chords in particular. You’ve probably already seen that the Dorico map chooses “long”. Choosing the default as “legato” means that without a slur, nimble playing is possible without using the shorts (which will kick in with the NoteLength conditions) and with a slur, of course the normal Dorico settings will ensure that the notes are joined. Lots of fun --and possible initial frustration-- to be had. The BBC library has little in the way of intermediate shorts like long or short detache and then the legato can become your only option.

I must have expressed myself badly. This is what I did, on the Dorico blog, and it’s going very well (the “long” articulation is chosen here by default), much better than the Babylonwaves template, which gives nothing by default (and the notes therefore do not play).

My problem is that I would also like to choose the same default articulation for the Sacconi Quartet from Spitfire audio (based on the Babylonwaves template, as there is no other thing). How do I choose a default articulation in Dorico’s Expression Map? I can’t see (I’m fairly new to Dorico).

Thanks, I understand. But as I write to Daniel below: I can’t find how to set or modify the default articulation…

I would suggest you map whatever you want the default sound to be to the ‘Natural’ playback technique in your expression map.

This is what I seek and cannot find. But it is probably my inexperience on this point. I will look again. It should not be rocket science, as we say in French. :wink:

here is the relevant bit. The arrows show what you should be looking at.

https://m.youtube.com/watch?v=2Mk0PWJWZOE


This will help I hope. It helped me
He explains articulations and playback pretty well

Thanks Mike and dko22, it’s really appreciated. I use this for BBC and everything is beautiful.

But my question is: how to create it if it does not exist (for Sacconi Quartet in my case)? And how to set it by default? You need the link between the expression map (which follows the orders) and Dorico (which says that without mention of articulation, Natural must be played.

the “natural” technique is by definition the default. Which actual patch you set it to is entirely up to you. With the majority of libraries it would most commonly be a long sustained patch but doesn’t have to be. In my own case with the BBC, I chose as “natural” the legato patch. This logically meant I had to create a new playing technique to correspond to the “long” in the BBC which I called “sostenuto”. If you haven’t tried creating your own p.t’s so far then the manual or various video tutorials will walk you through it.

I know this all the same in general. But I have found where the confusion comes from (at least my confusion).

If I add the “Natural” command in my Expression map (on an X articulation), it works fine. So I understand that Dorico is programmed to understand the “Natural” command as the default command. However, my Expression map for the Sacconi Quartet of Spifire audio, is imported from the Expressions maps of Babylonwaves for Cubase (https://www.babylonwaves.com/expression-maps/). Babylonwaves, I don’t know why or how, works without this “Natural” command at Cubase level (and it works). But if I import into Dorico, it doesn’t work anymore. Without the “Natural” command, there is nothing by default. This is what I did not understand. Babylonwaves’ Expression maps for the BBC was also like that. For the curious, I enclose 2 files of expression maps of Babylonwaves (violin 1 of Sacconi Quartet and Violins! Of BBC).
Babylonwaves.zip (4.56 KB)

yes, these are examples of where a Cubase map fails when you try to use it in Dorico because there is no natural defined. But it looks like you have now sorted it by creating one and then setting the keyswitch you want to be the default playback if I understand correctly.

Indeed, everything is fine. Thank you for your information. I hope it can be useful to the community. I must not be alone in asking myself this question.