Need to correct markers after midi import

I imported my music from Logic as midi and markers were created on the timecode staff from the file. I need to edit the timecode because it is missing the …:00.00 a that end. I also need to edit the name.

the time code should be 01:00:21:00.19 but this only shows up to the frame.

How do I fix this and how do I set this to always show the complete timecode?

What are the fields you’re expecting to be included in your timecode? Dorico supports the format HH:MM:SS:FF. What are the two additional fields in your timecode format?

Logic’s documentation has hours:minutes:seconds:frames.subframes. The engineer I’m working with also uses sub frames. The hit point for this cue is on subframe 19. So, does Dorico support subframes? If not. How do I manually change the text in the attached photo?

Dorico doesn’t support sub-frames, I’m afraid, no. You won’t be able to replace the timecode in the marker with text.

Well I need some kind of solution here….

Unfortunately I don’t have a good solution to offer you. You can manually change the text label in the marker to be the timecode including the subframe and hide the “real” timecode (via Engraving Options), but you will then not be able to also include a textual label.

Is the title editable?

Yes, via the Video panel in Write mode.