Need Urgent Help!

Hey there,

Last year, I installed Cubase Elements 7 on my computer and I entered the Activation Code but it crashed every time I clicked “Continue” so I didn’t put in much effort and stopped using it. A few days back, I realised I needed Cubase again I was trying to recover it. When I enter the activation code in the E Licenser, it says that the key has already been used whereas it has not been used. Today, I went to my Steinberg account and registered the product, and the activation date i is stated 16/8/13. I don’t know how but it is. Please, if someone could help me, it would be appreciated. I was overseas and when I went back to Australia, I asked the guy over there to help me out. As I didn’t have my product with me, he couldn’t help me much. But he did install a trial version of Cubase Elements 7 for me which was very helpful. Please help me. I have all the information with me and lost nothing.

Thanks and Regards,
Azmi Shakoor

You already activated your licence when you installed the first time…now you need a ere-activation, follow the instructions in the Knowledgebase.

https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/soft-elicenser-sel-faq.html#reactivation

Thanks for your help. It states that I must request for a new activation code. Now, could you please tell me how to do that?

The problem is that how do I get the new activation code? I think I am missing out something.
“Enter the new Soft-eLicenser number that has been created on your new system. The number is displayed by the eLicenser Control Center which can be found in the “Program Files” (Windows) or “Applications” (Mac) folder on your computer.”
Now, where do I get this new number from?

It will be there already if you follow the rest of the instructions properly.

Thanks a lot mate. It took me a while to figure out what was I doing wrong.