Neither "Render in Place" & "Audio MixDown" works

You guys have probably heard this before - neither “Render in Place” & “Audio MixDown” works.

I’ve spent hours trying to Render in Place. First hour - nothing. The second hour suddenly two tracks worked (red square below). Then it stopped working again. Then a third track worked again (EW Epic Choir), only to stop working again. The nothing whatsoever.

No combination of tricks I’ve seen in the forum seems to work consistently, and once a track stops working, it’s dead. And BTW, When I chose option “Keep Source Tracks Unchanged”, then it DOES CHANGE the tracks" (it disables Solo, and i also disables Solo on any Sent FX tracks and…).

DEFINITELY A BUG (cache something? Something internally “hangs”?).

I also tried File - Export - Audio MixDown; But it*s the same bat-s–it crazy thing; It produces only empty audio.

Does anyone from Steinberg read the forums? Why isn’t this crap fixed already? The Forum is full of complaints about this but no solution gives consistent results.

Image below shows “empty audio”.


Hm, after restarting the project, there’s a list of missing audio files (these were empty audio files which I deleted manually).


Why doesn’t this dialog have a button to clear any internal file references which obviously are missing?

Being a programmer myself makes my brain spin when seeing this kind of crappy software after so many people have complained about this not working properly. Probably because the files are full of invalid references, and no way of cleaning up the files?

// Rolf

Any links to other threads where the “issue” (if it is one) is described and complained about?
Thx, Ernst

If you see this happen, that is a sign of files being moved outside cubase/nuendo. Perhaps you copy, move or remove them yourself? You always have to let cubendo manage files, if you want to rename, use the pool. If you want to copy, move, remove unused references, etc, use pool and corresponding functions, there are enough of them.

In addition, as you say you are a programmer may I add this. Some versions of cubase do not ‘lock’ files, .e.g you can delete files on explorer while cubase is still using them even when the daw is running. Maybe this behaviour is wrong but perhaps necessary for external audio editors like WaveLab to work in conjunction. If you do such, like deleting files that are in use, anything like your first report can happen. Again we have to make sure to let cubase handle audio files, not by ourselves. It’s actually common in all the daw.

@TakashiWatanabe , thank you for the hint about the “Pool”. I didn’t know about that one.

It seems this project is destroyed since no rendering works, but I’ll use Pool from now on, perhaps the next project will work better…

@Elien , the keyword I used in the header will give you long lists of similar problems:

All the best,
// Rolf

1 Like

This may be dumb but are your tracks muted when you render ? You don’t mention that in any of you posts, so I assume they are not muted at the time you render, yet the screenshot shows the tracks are muted. Why is that?

muted tracks

1 Like

Hi @Louis_R ,
The tracks to be rendered are is set in Solo mode (including any routed output tracks) before I trigger the “Render in Place” command . Only during/after the rendering the tracks are automatically disabled by Cubase (despite setting the option “Keep Source Tracks Unchanged” in the Rendering dialog).

So, the screenshot only shows the state (muted) after rendering, not before.

(This is also why I get any audio file at all, but there’s no audio recorded, only an empty file as shown in the last track “Stereo out (R)”)

// Rolf

Then move the Cubase 12_64 folder out of AppData/Roaming/Steinberg and see what happens.
Do not delete it, just rename or put it somewhere else so you can put back your custom settings.

Hi again, I tried that but no go. Problem remains.

// Rolf

Then you project is corrupted :exploding_head:

Have you tried adding an exclusion in Windows Defender ( or whatever AV you run) for your Projects folder? Don’t forget to add one to whatever folder you render too as well. Let me know if this helps at all.

Hi @zenmastershake. Yes, I have tried that, but the problem remains.

I noticed now that some tracks further down can be rendered while some of the first tracks can’t.

(I also noticed that when I set one Send track (FX EchoBoy) to Solo, then one of the tracks (out of four) is also set to Solo almost like if the the buttons were physically “connected”. Crazy this. )

So it seems the project is corrupt with some tracks working (rendering), some doesn’t and some track’s Solo/Muted states are “linked” to it’s FX target.

I’m now trying to move (copy) track events over to a new project file to see if Rendering & MixDown works in a fresh project (hopefully the corruptions doesn’t copy over as well). In any case, the original project file is a corrupt corpse. If there’s any cpr-recovery/repair tools out there it would be interesting to identify what has gone wrong, but manually it seems I have no way of fixing the prj file.

In any case, thank you all very much for your attention and advice, I have learned much from your questions and so I may be likely to corrupt the project file in the future (especially using Pool to clean up unused files, a function which I didn’t know about before this thread).



I tried to move track events to a new project file, but the problem remains - some tracks can be rendered and others can’t be (in the new file the ones that worked and those who didn’t work were not the same tracks).

Such inconsistencies tells me this is less than HQ software with little or no internal sanity checking of data being processed, no error messages and just not bothering to do what it was expected to do.

Is there by any chance any log files that can be examined to get some clues?

// Rolf

How are you moving the tracks to the new Project ?
Do you open both projects at the same time and Drag and Drop the Events on an empty space (which automatically creates new tracks), or do you use Import from Project ?

In both cases it copies the whole track data, so if it is corrupted it will also corrupt the new project.
Although this is quite bizarre that the issue occurs on different tracks than with the original project.

Can you try creating the tracks first, then dropping the files on them ?
You’ll have to do it one by one in that case (if you drag and drop the Events). You can also import or drag and drop the audio files that are in the Audio folder of the project (which will create new clean tracks).

I copied the tracks and pasted it into the new project, so something bad seems to come with it. I’ll try the different approaches which you suggest.

I really appreciate your suggestions, and I will report back asap (perhaps after the weekend).

// Rolf

Copying the tracks is exactly the same thing, as the name of this function suggests, it copies the track data.

First of all, I have only MIDI tracks in this file (since I havenj’t been able to create any Audio renditions…

I have now tried (with a new project) to first create the new tracks, and then copy & paste the individual MIDI events, but the problem remains.

UPDATE: After restarting Cubase the newly copied events (on new pre-created tracks) now render as expected!

Thanks a lot for all the help!


1 Like

Nice, and the Render settings are now working as expected ? No weird mute/disable ?

Unfortunately that part is still not working (it disables Solo mode on rendering) despite using “Keep Source events unchanged”. But perhaps that doesn’t concern the track, only the events… Is there a global settings for the tracks, possibly?

The really bad thing with this is that the Solo mode for the send (target) channels are also disabled. This makes it hard to keep track of everything when so much can change.


// Rolf

It mutes the created track, regardless of the Source Events setting, which is not normal.

If we select Keep Source Events Unchanged, then yes, it should automatically mute the new track, since we most likely want to continue working on the original track.

However if we select Mute Source Events, it shouldn’t mute the new track. Since the original Event gets muted, we are expecting that the new track will not be muted so we can listen to it directly without having to click another time to unmute, but that’s not the case.

I wish some developers could take a deeper look into this issue.