Nektar P1 will not update firmware

New Nektar Panorama P1 with Cubase Pro 11 and Windows 10.
I would love to get some work done with my new P1 on this long Christmas weekend.
I’ve registered my new Panorama P1 and connected it via USB to the computer. According to Nektar’s instructions, I’m to run the P1 driver installer, which I did. Then it says to update the firmware BEFORE I install the Panorama Steinberg Support (that sequence makes no sense to me). if the selected MIDI ports do not appear as Panorama P1 in the MIDI channel list.
They do not. So I unplugged the P1, then plugged it back in holding down the Toggle and Mixer buttons. The P1 screen is white indicating readiness for firmware update. I then open nkupdate .exe which screen comes up and says Device Update Mode Not Detected and all the buttons are greyed out.
So I decided to install the Cubase support. Now the P1 shows up in the Studio/Devices. I add that and choose the MIDI in and out. However, the P1 will still not show up in the MIDI port setup.
Either my P1 is defective or the instructions are not complete and I’ve failed to do something correctly. Any help greatly appreciated. Thank you.

I had kind of the same problem with Nektar T1 : impossible to update the firmware.
i had to use another computer to do it. I think it has something to do with the USB2/Usb3 compatibility of nektar keyboard when updating the firmware

Thanks for the reply. Not sure that’s my problem The cable that came with the P1 is labeled “USB 2.0”. It’s plugged into a 2.0 port. Will try on my laptop and see if there’s some other problem I can track down. Tried to send message to Nektar support but that looks like a dead end. There was no “your question has been sent” message, merely an unintelligible piece of gibberish.

Hmmm…I apparently posted this in the Lounge. Didn’t mean to. Will copy and repost on Cubase forum.

Nektar P1 was attached to my rackmount computer with the USB 2.0 cable that came in the box plus a USB 2.0 extension cable. Just to test everything, I attached the P1 to my laptop using just the short cable that came with the P1. Everything installed perfectly on the laptop and I didn’t have to update the firmware in order to see the P1 in Cubase Studio’s MIDI channel list. BTW I tried it on the USB 3.0 slot and it still worked.
Went back to rackmount, attached P1 using only the “official” cable and still could not see P1 in the MIDI channel list although it appeared as a choice in “devices”. So, according to Nektar, that means that I need to update the firmware. When I attempted to do that, the P1 DID appear as “connected” in the update app box. It looked like it updated, but when I went to verify it, this appeared:
Device Attached

File Loaded

Verifying Firmware

Verifying Device’s Program Memory

Failure Verifying Program Memory: 2 in 12.07s

Firmware Validation Failed

Okay, So I disconnected everything from the rackmount and went back to the laptop where I attempted to update the firmware, even though it didn’t appear to need it on the laptop to work.
Firmware updated and verified. Went back to the rackmount, disconnected all synths from my MOTU, assigned Nektar to MIDI channel…it still did not appear and the P1 will not control Cubase in my rackmount Windows 10 computer.
I’m stuck.

Going through all the installation steps several times, uninstalling the P1 several times, just to be sure it wasn’t operator error, I finally got around to checking the gear, i.e. the USB cable. Yup. It’s not a bad cable, works perfectly with other connectors, but apparently the P1 doesn’t like it. Just a normal USB2.0 cable connected to a USB extension, but 12 feet long. Apparently the problem is in using a USB extension cable. See post following this one.
I went the wrong and more difficult way. Check the cable first, as I should have known. Will ask Nektar about any limitations on cable length.

Will keep this post up for anyone having the same problem.
There doesn’t appear to be any warning about cable lengths or combinations on the web, so I tested different cable lengths and combinations with what I have.

-Enclosed Nektar cable works fine.
-10’ USB 2.0 cable works fine, although there’s a slight delay between moving the physical fader and linking with Cubase 11 tracks.
-15’ regular USB cable works fine, same as 10’
-short extension USB cable in combination with long or short USB regular cables DOES NOT work
-long extension USB cable in combination with long or short USB regular cables DOES NOT work

I would have appreciated it if Nektar had done that work for me and listed problems with certain combinations of USB cables. They didn’t, and I’ve received no reply from Nektar Support.

Check out my findings on my latest posts in this topic.

Thanks for posting this. So overall is the P1 working in Cubase 11? About to buy one.


Works great. Got it because I do a lot of live improvising with plugins and virtual instruments., but it’s great as a control surface.
-Brian Wilson

Great, thanks for confirming. Ordered mine last night so that’s good news.

Mainly going to use it for sound design for VSTs and hardware synths. But will see if I end up using the Cubase control features as well.

Nice. I’m very happy with it. A little tweaky for some old hardware synths, but great for plugins, and just fine if you’re used to all the MIDI CC stuff.


Cool. Tweaky in what way? I’m probably going to use it to control CTRLR (MKS80 and a few others possibly).

[Image removed by sender.]
February 1

Cool. Tweaky in what way? I’m probably going to use it to control CTRLR (MKS80 and a few others possibly).


Not quirky, just takes a bit of time, no more than any other controller.

1 Like

Got mine today. Working fine for the most part. Think I saw this elsehwere but when editing the Control menu in Nektarine the changes aren’t reflected on the hardware.

If I do this in standalone it’s fine but loading back up in Cubase and it’s ignored. I was able to use the learn function and then save that internally for it to show.

Is there a way to get the Nektarine editor to change things when using Cubase?

I also tried saving internally when using the standalone Nektatine, but when I loaded that patch (internally) it was back to default.


Also is there a workaround for maps that need more than the 160 parameters per device Cubase supports?

I know we can re-order the ones we need. But some synths might actually need all of those.

Does using a VSTi in the wrapper help?

Hmmm. Didn’t have that problem but will check it out tomorrow.
-Brian Wilson


For instance Waldorf Largo has over 2000 internal parameters. So the map for that doesn’t load right, stuff is re-arragened. Worked fine in standalone Nektarine though.

Am I correct in thinking that the Nektarine plugin doesn’t work with P1? It doesn’t seem to connect to the hardware. If I load the map I make in the plugin in standalone it does work. I can copy it over to the common folder then.

Just not sure if there is any point in using the plugin for editing.

Turns out Largo in Cubase seems buggy for assigning the parameters. Relearned all 150 of them and it works but when I load that map into standalone Nektarine everything is all messed up, yet it works in Cubase.

And when I learn some of the buttons they assign ok but the labels are the wrong thing (they show correct initially but when you go back to the page they are incorrect).

At least it all works fine in Bitwig.