Neverending eLicenser problem

I just downloaded the last version of eLicencer Control Center ( and transferred my license from an older usb-eLicenser device to a new one. But sadly; It was exactly the same problems as I have been used to for much too long now:

At first the Dorico-window freezes on something “VST Audio Engine”-like, and then I get this:

eLicencer Control - Error
Application ‘Media Service’ has caused the following error:
The Soft-eLicenser threw an unknown exception.

After that, I get this:
eLicencer Control - Error
Application ‘Dorico LE 3’ has caused the following error:
Connection to protection device lost.

(I don’t even have Dorico LE 3!)

And after that; next try, I get this:

eLicencer Control - Error
Application ‘LCC2’ has caused the following error:
Application ‘’ could not be started.
Probably the file is corrupted or incompatible, or file access permissions are set incorrectly.
Please download and install the latest version of the eLicenser Control software from

Those messages sometimes come in a different order, sometimes only one or some of them, it all drives me crazy. And when I look into the eLicenser Control Center, I get a very unsecure feeling because a lot of the functions there seemes like it needs help all the time; “Maintenance”, “Recover”, “Repair” (… and now in fact; it can’t find my USB-eLicenser at all. I try to remove the dongle and put it back in again with no luck). And the software comes in new versions all the time… And the visual feeling of the fonts in the dialog boxes during installation seems somewhat … very old. (What is this ???)

Earlier today I managed, after some restarts and the usual hazzle, to get up and running with Dorico, and tonight I said to myself: I must try to fix this when I have time, not when I just have a few minutes or hours in between. So I quit Dorico and did the above described actions, dreaming that I maybe could fix it once and for all. Now it’s as bad as ever, after trying with a new device and the latest software!

It’s a Steinberg-thing, I know! But I have bought Dorico and want to be able to use it without having to fight Steinberg. Can’t somebody from Dorico march in at the Steinberg-office and tell the big boss there that you have this little, but very much complaining customer in Norway who won’t give you peace before this trouble is solved, once and for all!??

I don’t have the muscles to fight Steinberg, and as you have explained earlier, probably you don’t either. If it is like that, I must try again to get some more help from you, because I just can’t go on like this. And I love your software too much to just go back to Sibelius. So: Where could the problem be hiding?:

My computer: iMac (27-inch, Late 2012) 3,4 GHz Intel Core i7 MacOS Mojave 10.14.6 (18G103)

My eLicenser Control Center (eLC Version

My Dorico (version

Other places?

I still have Dorico ( and Dorico ( in my Applications folder. Is that a problem? Can I just put them in the trash, or do I need to uninstall or whatever?

This is not a minor problem. I need help that solves the problem.

  • Oddbjørn

The freezing Dorico-window says “Launced Audio Engine”.

I’m very sorry to hear about these problems you’re having. I’m pretty sure that removing Dorico 1 and 2 won’t have any impact on the behaviour of the eLicenser. I’ve sent you a temporary activation code for you to try adding to your Soft-eLicenser to see if that works more reliably. Please let me know how you get on.

Thank you! That’s great! I followed your instructions and started Dorico. I was not sure if I should answer “Continue Trial” or “Enter Activation Code” in the dialog that said “This is a trial version…”. Since I just added the activation code to my Soft-eLicenser, I felt that the right option would be to click “Continue Trial”. Hope I understood it right.

Dorico started with no trouble (hurray!), but I got this message:

“The current preset or project was created with a previous version of HALion Sonic SE. If you modify the preset using new features of this trial version, a previous version might not be able to load it or the preset might sound different.”

I didn’t really understand this message… Is there a newer version of HSSE than I have? (Mine is 3)

I clicked OK and the same dialog came one more time, and I clicked OK again.
Now there is no sound when I hit Play. I guess that’s an easy problem compared to the eLicenser-thing.

(In the project I opened, I use a combination of NotePerformer 3 and HALion Sonic SE 3 instruments).

Thank you very much so far! I hope you can help me the rest of the way here, right now I have other things to do, so don’t feel that you have to answer superfast!

To know that I can rest my shoulders and concentrate on the music for 90 days is of great value to me. :slight_smile:

Ups, I just tried to open another project, got the same message, clicked OK - but there was sound! I switched back to the first one, and now there was sound there too! Nice if you can just explain to me what is going on, and if it’s right to click “Continue Trial” :slight_smile:

You won’t see the ‘Continue Trial’ message again for another 10 days. But you did the right thing. Glad you’re now up and running. Get back in touch with me when your time-limited license is due to expire.

I will. Thank you! :slight_smile:

Hello again! - I would now normally have upgraded to 3.5. Since I use this trial activation code solution; Do I just upgrade as normal? Is there a chance that the e-Licencer problem is solved with the new version?

Yesterday I bought the Dorico update to 3.5 . I’m using for Dorico the soft elicencer. But I have for my Vienna Instruments also a hardware elicenser. Sinds yesterday I get, if I open a project with Vienna Instruments (Dorico or Logic Pro) also this comment:

eLicencer Control - Error
Application ‘LCC2’ has caused the following error:
Application ‘’ could not be started.
Probably the file is corrupted or incompatible, or file access permissions are set incorrectly.
Please download and install the latest version of the eLicenser Control software from

I had never before this problem. I’m using the newest software. After a restart of the computer sometimes it worked, but the problem came back. Could there be a connection with the update? What is LCC2?

LCC is Licence Control Center, I think.

Oddis is right.
@Maximilian: Try following workaround. In Spotlight just type elc and it will find the eLicenser Control Center. Just start that alone and leave it running, after that start Dorico or Logic. Do you then still get that error?

Oddis, you cannot update the time-limited license on your Soft-eLicenser. You’ll need to do battle with your USB-eLicenser, because that’s where your permanent license lives. Unfortunately the eLicenser team is still working on the update to eLicenser Control Center that will fix these problems once and for all, so I’m afraid I expect you will still encounter problems when you try to use your USB-eLicenser with Dorico 3.5 until the problem is properly fixed.

Thank you, Ulf! I did it before and all licences were not visible. I tried it now again, after a restart of the computer
and it seems that everything is okay.

Ok. Very good to hear that these problems one day will be fixed once and for all :slight_smile: Next question for me then will be: If I update to 3.5 now, battling with my USB-eLicencer, is it possible that you can give me a kind of new trial-licence for that version? By the way; It has been wonderful to use the trial-solution, knowing that I can trust Dorico to work each time.

Strange: After a summerpause from Dorico I returned now and had to use the USB-eLicencer. It worked with Dorico 3.1.10 but not with Dorico 3.5.10! I think I have the latest version of the eLicenser Control Center installed (

Just to check: do you realize that Dorico 3.5 is a paid upgrade?

Good point! How come I didn’t meet any payment question when I downloaded it? (I used the Download manager). Sorry for being so stupid; but can i just click the “Enter Activation Code” in the dialog that shows up when I launch 3.5 and enter the activation code I have from earlier? And then maybe some payment possibilities opens up? (When I have too much to do I seem to mess up the simplest things … )

Dear Oddis,
I am afraid there’s no automatic thing for this purchase. You must go through your MySteinberg account, purchase the upgrade (59€/$) IIRC and you will receive a new activation code. Open the e-licenser app, input this new activation code and your license is ok for 3.5.10 until next paid upgrade :wink:

All right, thank you - I’ll do that then!
Love to pay you for the wonderful work you are doing;)

Dear Oddis,
I am a simple user as you are, and I am very happy to pay for the wonderful tool the team is building here :blush: