NEW BUG in 6.0.3: Grid Overlay = scrolling/zooming VERY slow

I updated from 6.0.2 to 6.0.3 and this is a new bug that has caught me:

Preferences -> Event Display

When the Grid Overlay preference is active, horizontal zooming and scrolling in the project window slow to a CRAWL. It takes 1-2 seconds every iteration.

(However vertical scrolling seems largely unaffected and is almost as fast as it was in 6.0.2.)

As soon as the Grid Overlay Intensity slider is set all the way to the left, zooming and scrolling is fast once again, as it was in 6.0.2.

8-core Mac Pro, SL 10.6.8 64-bit kernel boot, Cubase 6.0.3 64-bit
NVIDIA GeForce GT 120 & NVIDIA GeForce 8800 GT

Good catch! thanks :wink:
It’s a pity, really, seeing as the Grid Overlay itself seems rather cool.

Hey orchetect,

I tried this out and horizontal scrolling seems just as snappy as always on my system.

Cubase 32-bit or 64-bit?
What OSX version?
32 or 64 bit kernel?
What video card(s)?

Just trying to narrow down any variables…

64 bit Cubase
10.6.7
32 bit kernel
NVIDIA GeForce 7300 GT

My Mac Pro is 2,1 but the first 8-core version.

I’m finding that scrolling, and horizontal and vertical zooming using key commands, are not affected. If I use the zoom tool though, there is a 1 or 2 second delay each time I click, whether I zoom in or out. I’m using 64-bit and graphics card is an NVIDIA GeForce 8800 GS. Changing the grid overlay intensity (a great feature btw) has no effect.

Hi all,
We can confirm that there is a performance issue with the new grid overlay feature in Cubase 6.0.3 under Mac OS X. Unfortunately, under Mac OS X the grid lines drawn are infinite outside the visible range (e.g. the Project Window), which puts a strain on the CPU. Please note that Cubase running under Windows is not affected.

Currently the only workaround is to disable the grid overlay (what a pity, now that it’s finally here). This can be achieved by turning the intensity slider (Preferences > Event Display section) entirely to the left.

We are sorry that this issue wasn’t detected before release. We aim to resolve it ASAP.

Thanks for choosing Cubase!

Helge Vogt
Product Marketing Manager Cubase
Steinberg Media Technologies GmbH

… and just when I thought PC users are the lucky ones ( this time ) …
I switched to scissors tool.

And there we have the PC- show stopper.
The scissors line has a hard time, following the mouse cursor.
Precise fast cutting is not possible with 6.0.3.

Jan

Hi, Helge.
I am on a PC but I also have a performance issue with Grid Overlay set to anywhere but minimum once the transpose track is added and events are drawn and their values modified. Here’s my original post: http://www.steinberg.net/forum/viewtopic.php?f=19&t=11336

Yep same here Win 7 -64 Cubase 6.0.3 64

And I thought I was going crazy :open_mouth:
The scissor tool has a problem when using the Grid Overlay. There is a very noticeable and annoying delay of the vertical line that followa the scissor. It works fine when Grid Overlay is disabled.
I am on PC W7 and using the latest Cubase update 6.0.4.

That’s odd because AFAIK, 6.0.4 fixed all the noticeable graphics sluggishness that was introduced in 6.0.3 for me.

Yes, it is weird. The problem didn’t exist before these latest updates. I suppose that they will continue to weed out the bugs.