New Cubase 9 Pro user needs help w/Tempo [re]detection issue

Okay, this one is a bit of a challenge for me, so I need help.

I started a cover of a song in Cubase. My steps originally:

  1. Record vocals entirely externally (in Audition), then cleaned them up in RX5.

  2. Imported both audio tracks into Cubase and aligned them by editing the original track to remove the mp3 0.5s start gap.

  3. Selected the main original track and did Project->Tempo Detection. During this phase, I halved the tempo because it seemed like 120 was very high for the song, but 65 was about right. This appears to be…incorrect, and is causing me problems. (More later.)

  4. Smooth and tweak tempo.

  5. Audio->Advanced->Set Definition from Tempo and wrote the data to the audio files.

After that, I was able to play on MIDI controllers and everything lined up properly between MIDI notes and my audio tracks.

dry cough Since then, I’ve been trying to lay down percussion on my MPC. We won’t get into the fact that my timing is suspect. I’ve spent a week and a half improving that. However, the fact that it’s at 62bpm right now, and that I need 1/32 notes to get what should be 1/16th notes is likely what’s exacerbating things. I figured this out by trying a faster song last night, and I wasn’t perfect, but I was a -lot- better after five takes than I was on this after 5-9 painstaking practise sessions.

So… I wanted to rework the tempo detection.

I’ve tried replacing the original song with the pristine, unmodified mp3 and done the re-edit to kill the 0.5s gap at the start (replacing it because the tempo information was previously written to the version in my project) and doing the full steps above. The second audio track is not problematic; it plays ball nicely, and syncs exactly to the new tempo. However, the MIDI tracks I’ve laid down are no longer synced after I do this.

Does anyone know and can anyone tell me how to re-work the tempo so that it’s basically doubled across the same playback speed, or alternatively how to re-detect the tempo and have my MIDI -stay- in sync? Audio seems to be no issue. MIDI is another story.

Any and all useful help would be greatly appreciated.



Before you change the tempo, make sure the MIDI Tracks are Musical Time base. There is an orange Note symbol. Then MIDI data will follow the tempo change.

Regarding the Audio events, if you want to shift the biginning of the event(s) on the track, enable the Music time base on the Audio tracks too. And if you want to change the tempo of the audio file while changing the Tempo of the project, select the audio event(s) and enable Musical Mode in the Info View of the Project window. You can do so also in the Pool.