New Customer:Cannot download purchased Cubase 11 Pro software


I wonder if anyone could help nplase. I recently upgraded from Cubase elements to(which I had not got around to using) to Cubase 11 Pro.

I bought the upgrade from the Steinberg online shop, and they sent me a download access code and invoice with proof of payment.

I then received an elicenser dongle in the pos t(with no supporting documentation).

I downloaded the elicenser software as well as the Steinberg Installation assistant.

However the access code I was given does not appear to be associated with any license. This is despite me Paying £405 (nearly 500euro/$) for it.

I have created a ticket with steinberg customer services but so far, no response.

Not quite ready to get really annoyed yet, but that will come if I can’t download the DAW software that I paid for.

Can anyone help?

Greetings, and welcome to the Forum. I’m sorry you are experiencing this as your first introduction to such a cool product. i don’t know if I can be of too much help.

It sounds like you have the code, but you are not putting it in the right place…

The code you were given will likely work in the download assistant.
You called something an instillation assistant, but check again and make sure that I am right, and that it is actually the “download” assistant.

Many thanks for the input OQion.

I’ll try what you suggested.

But I am not sure the fault is mine - it seems to be saying there is no license in my name or associated with the USB dongle they sent me.

  • Can you post an image of your elc with all licenses showing?
  • btw, The download access code should be entered in the Download Assistant.

Did you first activate a license for the product you are are updating from? That’s the prerequisite. It has to be on the key in order for the update to take place.

I don’t think I activated the Elements software that I upgraded from.

However now when I try to run Download assistant it comes up with an message saying ‘error invoking method’ so I can go no further.

Any help appreciated.

Hi. Please remove that picture and remember to always blur the serials when posting pictures.

In the eLicenser Control Center:

If you click on the USB- eLicenser what is showing up in the right window under Licenses ?
If you click on the Soft - eLicenser what is showing up in the right window under Licenses ?

Nothing showing under licences


I did’nt. But I can’t activate or do anything now because all I get is an error when I try run the download installer. It says ‘error invoking method’, I have tried ther previously suggested fix of changing the default location of the installer on my C drive, but that has not worked.

Really I realise that it is no-one heres fault, but if I had known how difficult/impossible
it was to even install I perhaps would have gone with a competitor.

Does anyone know how long it usually takes Steinberg customer services to respond?

I contacted them a week ago because i am finding my purchased software impossible to install but so far no response.

Any advice appreciated>


It depends on the amount of issues they have to solve.

Could you describe your problem, maybe we can help you here on the forum.

Thanks for the reply. My issues are:

  1. I can’t run the steinberg download installer, it keeps coming up with an error message 'metod error.

  2. I bought Cubase Elements last year but did not download/activate it.

  3. I bought an upgrade to Cubase 11 pro about two weeks ago. My understanding is that i first had to activate the Elements software to enable the upgrade licence. However when i try to activate Elements using the code sent to me - it says licence already activated( which is not the case).

  4. Not being able to activate/download the elements licence means i think i cannot download the pro upgrade, certainly when i try to this i have no success.

Any advice appreciated


Could you please attach a screenshot of the error message?

Right. First, you have to activate Cubase Elements to the Soft-eLicenser. Then you have to transfer the license to the USB-eLicenser, to be able to upgrade the license. Then, you can upgrade the license.

Did you enter the Activation Code to the eLCC application? Does it start with 0240? Or did you use the Download Access Code by mistake?

Right, you cannot activate the upgrade before Cubase Elements activation.

@theodoreevans446 please stay with this topic, and don’t start another for the same problem. I have merged your two topics.

Thanks Martin for your attention to my issue.

When I try to install run the download assistant it keeps coming up with an error message saying ‘error invoking method’ those are the exact words, and I can go no further.

I used the activation code for Cubase Elements that was sent to me on purchase las tOctober, however when I enter it - the message reads activation code already used(which is not the case) and I consequently cannot download the Cubase 11 Pro Software.

I’ve got to say I find the whole process of trying to install my expensive software purchase very difficult and frustrating. That might be fine if I could get Steinberg Customer services to respond to my query but so far they have ignored it.

I can’t really afford to find another £500 for DAW software, so I am not sure what the alternative is, but there is no way that I am going to accept the Steinberg can just take my money and give nothing in return, without there being some consequence for them, even if that only means rubbishing them on the various music forums that I am a member of .

Of course I’d rather not go this route, life is too short, I just want a service person to talk me through what’s going wrong and how to fix the installation…