New Dorico 3.5 Freeze on Save / Playback / VSTAudioEngine3 Crashes on Document Open

Hi There, I just upgraded from Dorico 2 Pro to Dorico 3.5 Pro.

  • Previous install of Dorico 2 worked fine and could access my audio device correctly.
  • Spotify, Logic Pro X, etc. can access my audio device correctly.
  • macOS 10.14.6
  • Dorico
  • AudioEngine

It would freeze upon:

  • Trying to save.
  • Trying to quit Dorico after opening or creating a new document without saving. (Related to VSTAudioEngine3 already being dead?)

Note entry does not produce audio playback. Ability to playback is disabled / greyed out.

I’ve nuked all installs of Dorico 2 and Dorico 3.5 and searched my system to ensure it and manually removed everything.

sudo -i
cd /
find * | grep Dorico
find * | grep Steinberg

I’ve reinstalled Dorico 3.5 and the additional sounds library, and am running into the same issues.

I’ve also tried:

  • Forcing removal of the quarantine flag for both Dorico AND VSTAudioEngine 3 (though it’s recursive so it shouldn’t matter) via
sudo xattr -r -d
  • Renaming any and all VST-related folders.
  • Resigning Dorico with a self-signed key to enable (this showed up in the Console as denied).
  • Installing an update for the eLicenser and running maintenance tasks.
  • Removing - resulted in freeze on “Audio engine process died”

Interesting note:

  1. Launch Dorico 3.5
  2. Go to Settings > Play
  3. Open Device Setup
  4. (Everything enumerates correctly.)
  5. Launch a Document (either a new or template).
  6. Edit > Device Setup
  7. “Error connecting to audio engine”
  8. VST Engine is no longer present in Activity Monitor, sampling the process confirms it no longer exists.

Note: I have not completely uninstalled and reinstalled the eLicense Manager, only updated it.
Update: Uninstalling the eLicense Manager and reinstalling it had no effect.
Dorico (469 KB)

Also adding VstAudioEngine3 crash logs. I’ve ran the process from Dorico, separately from Dorico, and in terminal separately from Dorico. (199 KB)

Please see my private message.

Hello - I’m having a similar issue. Mine is crashing on startup. I’m attaching the audio engine crash log, I wonder if you would take a look? Thanks! (27.1 KB)

Hi Elliot, did you install some new plug-in or moved things around? It looks like the plug-in-manager is stuck in an endless loop while scanning plug-ins. This may happen when the plug-in-manager encounters symbolic links to plugs rather than the real bundle. So please check if that might be the case with you. Also please do ‘Help > Create Diagnostics Report’ and post the corresponding zip file. Thanks

Thank you, this fixed it. I did have a circular folder shortcut situation in my VST directory. I appreciate your help!

I’m glad to hear :slight_smile: