New Paragraph Style From Selection Causes Dorico To Become Unresponsive

Reproduced several times:

  • Open Paragraph Styles dialog
  • Select Default Text
  • Create New Paragraph Style From Selection
  • Change leading to 104%
  • Save and close dialog

Dorico is now unresponsive.

I don’t find this to be the cae, windrag. Is it possible that you have another modal dialog open somewhere, for example on another display, that makes it appear that Dorico is unresponsive when in fact it’s just blocked by a dialog on another display?

I don’t have another display, and each time this has happened I open Dorico and open the Paragraph Styles dialog, so there are no other dialogs. I’m thinking it may be a font problem. I’m going to change the default font back to Academico and see if I get the same behavior.

I’m unclear about how text styles work. I opened the Font Styles… dialog and changed the Default Text Font to Academico from what it was set to. I then go to the Paragraph Styles dialog, and the old font shows under Default Text. At what point should the change be reflected?

It shouldn’t. There are two different default text styles, one for Paragraph Styles and one for Font Styles. They’re not linked to each other in any way.

Thanks, Leo. I was able to change my Default Text Font back to Academico from what it was set to (Plantin). That didn’t cause any problem. When I tried to change the Default Text Paragraph Style back to Academico, once I click OK in the dialog, Dorico hangs with the SBOD (Spinning Beachball of Death) on Mac.

Please take a sample of what Dorico is doing by going to Activity Monitor, selecting the Dorico process, and choosing Sample Process from the cog menu at the top of the window, then zip up and attach the resulting file here.

Here you go:

I verified all of my fonts with Font Book. Only two minor issues show up: one with Bravura and one with Tamburo. Neither was being used as a text font, obviously.
Sample of (25.7 KB)

windrag, does this problem occur in all projects, or just in one specific one you’re working on? E.g. if you create a new project based on the Piano template and create a new paragraph style there, does Dorico still hang? I’m guessing that it won’t, in which case we’re going to need to see the specific project that’s causing the problem. Please either zip it up and attach it here, or email it to me at d dot spreadbury at steinberg dot de and I’ll take a closer look.

I followed your instructions, and it appears that on my machine, Dorico will hang any time I try to change the Default Text paragraph style font. I haven’t tried to change others, but I can keep experimenting if that’s helpful. Tried a couple of different fonts, and the result is the same. This happens in a new project started with the Solo Piano template.
200930 Sample of Dorico .zip (26.4 KB)

This is not a general problem, so please do Help > Create Diagnostic Report and attach the zip file that is saved to your desktop so I can take a look. The diagnostic report will include some other data I can take a look at to try and figure out what might be going wrong.

Here you go. Thanks, Daniel.
Dorico (1.15 MB)

Thanks for the data. Unfortunately there’s no smoking gun therein! The one log in the diagnostics that shows the problem occurred (because the log is truncated at the point at which you are working in the Paragraph Styles dialog) shows that you created a new project, switched to Engrave mode, did something in Engrave > Music Fonts, then did something in Engrave > Font Styles, then finally went to Engrave > Paragraph Styles and did something there. I’ve tried to walk through the same steps: I assume you changed to Petaluma in Music Fonts, edited the ‘Default Text Font’ font style in Font Styles, and then duplicated the ‘Default Text’ paragraph style, then clicked OK. However, I simply can’t reproduce the problem so at the moment I’m somewhat stumped.

Could you please try quitting Dorico and then moving aside the “Dorico 3.5” folder in %APPDATA%\Steinberg, then running Dorico again so that it runs with factory settings, and see if you can still reproduce the problem in a new project?

I’m assuming you mean ~Library/Application Support/Steinberg/Dorico 3.5 since I’m on a Mac?

Sorry, yes, indeed I do mean that.

I moved the indicated folder to the desktop, opened a new solo piano project, and was able to change the default paragraph style without issue.

Is it now just a matter of re-creating my custom key commands to get back to where I was?

Well, that’s very interesting, because I tried to reproduce the problem with the files from your Dorico 3.5 folder (most of which are included in the diagnostic report you sent me) and wasn’t able to. So I think what might be interesting is to put each of the files with .xml file extensions back one by one and see which one appears to cause the problem, then let me know.

Thanks, Daniel. I followed your instructions. All was fine with several files, until I got to layoutOptions_scores.xml. I’ve zipped it up for you. (3.15 KB)

Thanks very much for sticking with me. Now we can see what the problem is. The issue is that if you have the option to show the “chord diagrams used” frame set in your layout, Dorico will get into a deadlock state when trying to make changes via the Paragraph Styles dialog. This is a bug, which we will fix, but in the meantime you should be able to work around it by temporarily turning off the chord diagrams frame in Layout Options. Sorry for the inconvenience caused!

Great, Daniel! I’m glad you were able to figure that out. Happy to stick with it, and happy to help find bugs.

Edit: I’m a little confused by this, though. Do Layout Options persist even when starting a new file? I was launching Dorico fresh and then opening up a new solo piano template. Wouldn’t the chord diagrams be turned off by default? By what mechanism does that particular setting become applied to a solo piano score?