New Solo piano project using the HUB - Time signature and Key signature problem

I am still new to Dorico, and I want to start a new Solo piano score. In the HUB, under Create New, I found the option to set the Time Signature and Key Signature (right hand side of the HUB window)
Somehow I am unable to change the values in these fields. (I tried mouse and keyboard in all sorts of combinations …)
Changing the number of bars seem to work.
But I am unable to change the Music font, Text font, Time signature and Key signature. Am I doing something wrong?

These options appear to work fine here, on MacOS 12.6, running Dorico Pro 4.2., either using mouse for everything or by tabbing between fields/spinboxes/menus, then using Space to open a menu, up/down arrows to select the correct option and Enter to confirm it.

(I do note that if a project is already open with something selected on the page, keyboard entry on the Hub is harder as the open project seems to want to grab focus. I also note that Tabbing between fields is a little tricky as the relevant field doesn’t show focus with the usual blue highlight.)

What version of Dorico are you running, under what operating system, and do these fields show white or greyed out? Is this a factory Solo Piano template or one you’ve constructed and added to the Custom Templates?

Thanks for the reply! I am running Windows 11 and Dorico SE 4.2 and I try to use the factory Solo piano template.
When I click in the Project title field, it has focus and can be edited. Tab moves to the Composer field as expected. Than the next tab makes the focus disappear and after a few tab hits, it re-appears in the Bars field allowing to edit this field. The fields ‘Page size’ and others are normal grey (not 'greyed out) and can even turn black but editing is never possible. So I guess there is indeed an issue with how Windows handles the focus and treats these fields. …

After some more experimenting (and your tips), I found out that editing these fields becomes possible after hitting the space bar … So not really intuitive nor Windows normal practice …
Thanks again and cheers! (I go write a piano sonate that changes the world :wink:

There must be something non-standard about your setup. I have Win11 and can access all fields on the hub without difficulty.

I suspect the 4K monitors (high DPI) have something to do with the problem. For the rest I just have a normal Windows 11 Home, without fancy configuration things.


You made me think …
The solution turns out to be changing the properties of the .exe and select: change high DPI settings to ‘System (Enhanced)’
Now Dorico seems to behave ‘normal’.
Cheers! and Thanks again!