New switch Stereo/Mono button resets VST2 inserts to default value

Hello!

When i use the new convert Mono to Stereo button on Audio tracks some inserts are reset to their default values.
For example if I have a stereo audio track with a Guitar Rig instance loaded and a preset selected when i switch to mono the Insert is reset to the default value.

This does not seem to happen with default Cubase plugins but i tried several third party ones and it regularly resets all the settings as if it is reinserting the plugin from scratch.

Hi,

I’m sorry, I’m not a Guitar Rig expert… Does it have dedicated stereo- and other mono plug-in version by any chance?

Heya Martin,

Nopes there is only one instance, this happens with MaschineFX as well, I tried some free ones such as NadIR (they seem to have just one instance there is no Guitar Rig and Guitar Rig Mono so to speak).

All of these are reset for example
image

VOXENGO SPAN too (there is only one dll)

Hi,

Are you on Windows or Mac, please? Which version?

Yes certainly:
I am on Windows 10 v.22H2
i9-9900K and 32GB of RAM

I am using Guitar Rig 5, Maschine2 FX, Absynth 5 FX (it seems that Native Instruments plugins are particularly affected, but NOT all of them for example Replika or Driver are fine).

I don’t know if it helps but in the case of Maschine and Guitar Rig, if i have the instance visible i see that disappearing and reappearing when switching from mono to stereo.
The stock ones do not do that (however can be these 2 are slower to instantiate so it looks like they disappear and reappear).

Ok this is maybe easier to repro,

I just downloaded the most recent Voxengo SPAN version.

Installed only the VST 3 one
image

Cubase Create Empty, Audio track Stereo and i add the new version

Convert to mono and the plugin flashes, in my case it even becomes unusable

1 Like

Is the SPAN version you have downloaded different from the one you are instantiating in Cubase 13? For the screenshots, it seems you installed v3.19 VST3 but instantiated older v3.1 VST2 x64. Could it be?

Can confirm that converting mono to stereo consistently resets Insert Effect to default settings. (Have tried multiple times just to rule out user error)

In my case OHMBOYZ delay.

System details in my Bio.

Yep sorry my bad, you are correct.

(edited the topic title accordingly)
@Martin.Jirsak So thanks to @Jorge_Ruiz I realized that happens with (any) VST2 plugin, not VST3

This explains why Driver and Replika worked
image

1 Like

Hi,

Thank you very much for the investigation!

At this moment, I have only a Mac M1 computer, so I cannot test VST2 plug-ins. But I will have a look on Monday at a Windows system.

Thank you again, great job!

1 Like

My pleasure Martin thank you very much for looking into this.
That’s not a blocker for me but being the Mono/ Stereo switch a new feature and being VST2 plugins sometimes the only option perhaps many other users will have this issue.
All good from me.
Cheers

Hello!

Has this be confirmed to be a bug and will be possibly fixed in the future or should I live with it?
My issues is that I still have VST2 plugins that do not work with the new Mono to Stereo button.