New TOOLS for UR28M and UR824 version 2.0.1 for Mac OS X

Steinberg has released new TOOLS for UR28M and UR824 version 2.0.1 for Mac OS X.
The free update fixes some minor issues and ensures compatibility with Mac OS X 10.9 (Mavericks).

Please find the update for UR28M here.

Please find the update for UR824 here.

I’ve been eagerly awaiting this update, but unfortunately it is not working on my brand new iMac running Mavericks. Completely uninstalled the old drivers, rebooted a couple of times, installed new 2.01 driver, rebooted, connected the UR824 - any audio or video file turns to complete noise within 1 minute of playing.

So my 3.8ghz i7, with 16gb ram, 3tb fusion drive, stutters like a 1985 286.

As soon as I set output back to the “Internal Speakers” option - or even using my Pod HD500 as an interface with outputs routed back to the UR824, everything is fine.

Unfortunately, I don’t believe 2.0.1 has solved the noise problem with Mavericks.

sadly Noel

I have checked the TOOLS 2.0.1 again on my Mac Mini here running Cubase 7.0.6 and the UR824 with firmware 2.0.0 and the playback runs fine for almost an hour now. As we haven’t come across this before, I will contact development on this. Are there any other users here with this issue and a similar setup?

Does increasing the latency have any positive effect on this? Are there any other USB video or audio interfaces connected while using the UR824?

Well, the only place I seem to be able to control latency is in Cubase under Device Setup…none of the OSX drivers or tools seem to allow any tweaking of buffer sizes or latency? - audio midi setup seems to take a sample rate change as the only choice? But in Cubase, I can set the buffer to 2048 samples. Within Cubase, that sort of works, but any other audio file I try - e.g., iTunes, Youtube via safari or chrome, .mov files locally, and any other DAW, e.g., Live, all start completely breaking down after about 30-40 seconds of playback.

I do have a Line6 POD HD500 showing up as a 2 channel interface. In fact, if I use it as input and output, and route its outputs to the UR824, that’s my only real workaround at the moment. Internal speakers also work fine on the troubled audio.

Is there any other way to control latency on the unit, outside of the Cubase setup windows?

Thanks, Noel

One more thing…I did try upping the sample buffers to 2048 within Live as well…and still have breakups and smoked up audio there, within 10 seconds of playback. As before…goes away when I switch off the UR824 in audio setup.

Also, I did report this to Steinberg support, and have offered to try out any beta versions or other testing items they might need if it will help.


It’s only Cubase I was referring to indeed. I will have a chance to check this on a similar setup tomorrow and let you know! Sorry for this!
It would be helpful if you could send a system profile to info at steinberg dot de and put my name into the subject.

I wasn’t able to reproduce this here with any Mac system including a late 2012 iMac. I have forwarded this to development now and have to wait for a reply. All I can do at the moment is to ask for some additional patience on this matter. Sorry!

Thanks for trying. That’s frustrating that you don’t see this though.

After I got the machine, I actually did a full reinstall of the OS clean, added the driver, had the problem, removed the driver. It definitely seems to be the 1.8.3 USB driver at the heart of this, and I believe there’s at least one other poster on the boards with similar issues. I’ll stay tuned from support though.

  • Noel

Yes, there is one in the German part as well. It could be the USB 3 controller on the iMac but that is only a guess. Thanks for your patience!
BTW if other users have the same issue, please let me know here!

That makes a lot of sense, esp if you’re testing on usb2. Fwiw, I did test with cable direct to iMac, to rule out any hub issues.

I appreciate your diligence here …thanks!

Oh ho! The plot thickens.

Missed on note on noting that Mavericks users of hw products needs to apply another patch:

At, there’s a note that “Users of USB audio class compliant audio interfaces (no separate driver installation needed) are also required to run the CoreAudio2ASIO patch …”

The weird thing is that this patch is not on the UR824 page, but rather a download on the Cubase 7 page, so it’s a bit hidden.

I downloaded the patch and applied it, and initially thought the problem was fixed. It’s a lot better than it had been, but unfortunately, it did not hold. 100 bars into a Live project, with a sample buffer of 1024 samples, it started honking up again. Argh! Thought I had it beat there for a minute or two…


Sorry to keep updating this, but in addition, these problems are, after all, occurring with both Cubase 7.0.6 (even after the CoreAudio2ASIO patch) and in Halion Sonic.

Misc, Scott

This plot gets thicker than molasses in a driveshaft.

So over on the Apple Support forums, there is a 700+post thread of people troubleshooting USB3 problems on the late 2013 iMac. Far as I can tell, some very knowledgeable people have decided that there are actually 2 problems with related symptoms:

  1. There is a problem with audio drivers of all kinds when using a USB interface with an iMac with a Fusion Drive. This one appears to be Apple’s bug.

  2. There ALSO appears to be core audio issues with USB2 interfaces and the USB3 ports in the iMac. This one appears to be a combination of factors - likely, vendor drivers that take advantage of slightly-less-than-documented features (probably power related) in the USB2 spec that don’t translate to USB3. If you read through the thread, people with interfaces of all kinds have run into this…Focusrite, Apogee, many others.

My guess is that in my specific case, the latest Steinberg drivers may be addressing issue 2, but not issue 1. Or I’m still seeing both. In any event, I’m not the only person with a late 2013 iMac, Fusion drive, and USB issues that make using my new computer for music…pretty much impossible.

This thread is unbelievable but it’s clear at least that I’m not just individually crazy. It does lead one to despair that getting both Apple and our interface vendors to sort all these problems out without finger pointing…well, how long can we wait?

Workarounds include using FW interfaces (which don’t have these problems, but I just GOT my UR824!), removing or replacing the fusion drives until Apple fixes these problems (after a long battle with Apple to swap out machines), or repartitioning the fusion drive to “untie” the SSD partition from the mechanical partition. Eugh. What a mess.

One of the better commentators describes the options thus:

Its the Fusion Drive issue… which affects all types of Audio Interfaces (FW and USB) as well as Internal Audio…


  1. Create a bootable OS X external Disk, Boot from that and then install Logic on it… and use that for Logic/Any Audio work…for the time being… until a fix is released by Apple for this issue. Make sure you do not access any data on the FD drive after booting from the external drive otherwise the issue will reappear. until you restart your Mac and reboot from the EXT drive… You can however, boot from the FD when not doing Audio related work.

  2. Split your Fusion drive into an SSD and a Mech drive (again for the time being) and then reassemble the FD after the fix has been issued.

  3. Return your iMac for one with an SSD or mech drive inside (if you still can…)

  4. Do nothing and wait until Apple releases a fix for the problem… though there is no official ETA for any such fix…

Additional: Any USB2 Interface connected to a USB3 port may also have issues due to the USB2 > USB3 problem with newer Macs… This issue requires updates from the Manufacturer of the Interface to fix the problem…

Note: I run several different Motu interfaces with my 2013 iMac that doesn’t have an FD fitted… using the FW to TBolt adapter with the latest Motu drivers and Mavericks… and I have had no issues… (Though admittedly I haven’t tried an 8Pre this way but I don’t see why that would have a specific issue as they all use the same drivers…) Who told you it was not supported?

Anyway, late model mac buyers…This is the worst experience with mac’s I’ve had in 10 years as a mac user. If you get a new iMac, avoid the Fusion Drives until this is sorted, in any case. You’ve been warned, along with 47 pages of commentators on the Apple forums.

NoelEiffe, thank you for the update from your end! The development team in Japan is testing this issue and we are also in contact with Apple on this.
We’ll try everything we can from our side but it looks like Apple needs to address this as well.