New unsupported Midex 3/8 drivers available

… and I can answer my own question unfortunately with yes, there is a problem using the Midex with a Z170 mainboard, however it’s easily fixed.

For people in a hurry, with a free PCI/PCIe slot: plug in a USB2 card and use that for the Midex.

The longer, more technical answer: it seems that the Z170 chipset no longer supports the legacy USB modes that the Midex relies on. It look like there is a process whereby the chip in the Midex needs to load its firmware after it’s been plugged in, and this is where it’s failing, possibly as the Z170 no longer support EHCI.

Luckily In my case, there is also a USB 3.1 port on the mainboard (provided by a seperate ASMedia ASM1142 controller) and plugging the Midex into that solved all the problems. It’s incredible and somewhat ironic to think that I am able to keep such an old device alive by using a 10GBit/s USB port!

Happy days! :sunglasses:

For years I was really sad about losing support for products, but this thing with MIDEX is what companies should do in the first place, support it as long as there are users using your product, Go Steiny!!! Now bring back my virtual guitarist2 !!! (well it’s still working in windows 10 with C8.5.20 :slight_smile:

Quick search,

Apparently it should work with Win 10 64-bit

http://www.soundonsound.com/forum/viewtopic.php?f=20&t=46313#432104

Think I’ll still wait though!

George Wood

It does, perfectly.

does anyone have the original midex 3 driver cd??
that includes the original mac os driver (for mac os 9)
???

http://macos9lives.com/smforum/index.php?topic=3432

Bravo SB!!!

:smiley: Hello everybody,

if you tried to get the Midex 8 working in Mac OS X El Capitan .11 and Sierra .12 (one day old) at my MacMini(2012), it is possible !!!
I use Logic9 (yes very old) but i think it is working in Logic 10 and other Programms, too.

here is a picture of my mac desktop where you can see it:
https://picload.org/image/rdlacloi/bildschirmfoto2016-10-20um00.4.png

But sometimes it is a little bit unreliable to start it. Once it runs then it runs till the next reboot.
The other disadvantage is that I need Parallels 10 with Windows 7 to start the driver.
But we want it to run! :arrow_right: :arrow_right: :arrow_right:

I used the last unoffical mac driver from steinberg:
http://www.steinberg.net/index.php?id=915&L=1

I open the Audio-MIDI-Setup.app in Utilities. There I want to see the Midex in white border.
I open Paralells 10 with Windows 7.

Then I connect/disconnect the USB Items in the titlebar from Paralles. Sometimes the Midex is showing then in the Audio-Midi-Setup.app. If not then I disconnect, then connect the USB cable in the MAC. A popup shows me which of the computer i wish to connect with the midex (Win7 Parallels or MacMini). there i choose the MacMini. Sometime it is needed to be testing different connect / disconnect options. Mostly it is functionally when i disconnect & connect the cable.

I don´t know if it possible with an other Virtual Machine like Virtual Box or such an USB connecting / disconnecting programm.

Hope this can help anyone of you! :sunglasses:

André Müller

I have been using this driver without any problem on Cubase 8.5 (Win 7). But now I am on Cubase Pro 9.0.10 and I have timing issues. When I record within a new arrangement at a tempo of 90BPM the midi events are placed approx 2.5 frames ahead (too early) in my timeline (at 30fps) :frowning:

Is this the end of Midex 8?

FYI: when I do the same within my (still installed) Cubase 8.5, Midex 8 works fine!
FYI: When I use my other keyboard connected with an USB lead (instead of using MIDI through Midex). There is no issue at all.

Anyone any tips?

All the best,
Daniël

The MIDI port setup has changed a little bit in Cubase 9. In Preferences, MIDI Port Setup, have you tried with “Use Device ‘DirectMusic’” unchecked and “Use System Timestamp for Windows MIDI Inputs” checked?

You may need to restart Cubase if you make a change. You should see only “Windows MIDI” in the Device column.

Just wanted to say a massive thank you, I’d been sat here for the past hour trying to get my midex to work on my new x99 system after foolishly spending the last few days installing all of my software first.

Although I need to fully test it, it simply wasn’t installing properly and causing my system to hang on restart. The general consensus of the Internet was that it worked on win10 otherwise I wouldn’t have considered moving systems.

As soon as I tried it in the usb 3.1 port it installed straight away and appears to be working fine.

Big respect for picking this up.

Good to hear!

As a matter of interest, do you know if the USB 3.1 controller on your motherboard is the same ASMedia ASM1142?

my trusty midex 8 has ceased to work following one of the recent windows 10 updates. Might be a long shot but doesn’t hurt to ask: any plans to update midex drivers to current win10 incarnation?

I’ll give these drivers a try on my Windows 10 Pro v1709, although I’m considering installing the Windows 10 v1809 update. I use the Steinberg UR824 for audio now, which does not have any MIDI capability (like my previous audio interface did).

I haven’t done any MIDI in years. The bigger immediate problem is that I have misplaced the MIDEX 8 power supply since my last studio move. I’m sure it is around here somewhere. If anyone can post a photo of the USA version of the MIDEX 8 power supply, that could help me spot it in one of my many equipment junk boxes and bags.

The MIDEX-8 is USB-powered and doesn’t need a seperate power supply. The power connector is for an optional 6V supply but it’s only needed if you’re plugging it into an unpowered USB hub (which is not recommended for optimal MIDI timing in any case).

(Sorry just saw this post now). The MIDEX-3 and MIDEX-8 both work perfectly in Windows 10 with the new unsupported drivers.

too late for me, ended up selling the midex 8 and replacing it with ESI M8U-eX, but thanks for the update!

That’s one I’ve had my eye on as well – there aren’t many options for 8-port USB MIDI interfaces! I’d be interested to know how you get on with it.

Rock solid. Only drawback is the default setting is no output signal at all vs signal at all outputs in standalone (no allocated MIDI track in Cubase session).

This driver still works perfectly in Win10/1809. DirectMusic timestamping (LTB) is fully intact in Cubase 10.0.40. I did some tests on my system (i7 4790K @ 4.4 GHz, Z97 mainboard, Midex 8 connected to internal USB3 port).

Test scenario:

  1. Connected MIDI Out 8 to MIDI In 8.
  2. Set up a project 120 bpm in Cubase.
  3. Created a source track with 32 MIDI notes, sent to MIDI Out 8.
  4. Recorded from MIDI In 8 on a seperate track.
  5. Did this for Direct Music ports and Windows MIDI ports, both with ‘Use system timestamp’ on/off.
  6. Did this for 3 load scenarios: No load, 40% load @ 128 samples buffer, 70% load peaking with 64 samples buffer.

The load scenarios means a big project with ~ 30 HSO tracks in 2 instances of HALion Sonic 3, 3 x UJAM Virtual Guitarist, Valhalla Vintage Verb, GA SE with Simon Phillips Studio drums, some instances of DEXed, one Jbridged instance of Steinberg Virtual Guitarist 2. So a really busy project.

See the results in the attached images.

Source (sent out):
Results.PNG
Recorded (example):
Example_measure.PNG
Result sheet:
Source_Track.PNG

I haven’t tested the latency/jitter yet, but can report that I just racked up my old M8 and that it works very nicely indeed with Windows 10 1903 + C9.5. We’ll see how it fares with 10.5 when it arrives :slight_smile:

j,