new update10.5.10 !!!????...same error!!!!

thanks Steinberg!!! i’ve updated, but not resolve nothing… mcdsp crash arousor crash …with mac osx mojave !!! so i’ve pay for a program that not can use! so 10.0 rock solid release !same plugins , same osx mojave , same machine macmini i7 late 2012 16gb !!!
and now??? you have my money and i not can use new 10.5 !

Why do you people not simply use the trial first…? I know from my own experience, that Steinberg does not force anyone to buy anything… :unamused:

Trash your Cubase preferences

Seems to be a other Mojave disaster. My Native Instrumets get blacklisted and starting 10.5.10 seems to take for ever (at least the first time after install)

because I’m a cubase user from Atari Version! and this is the first time i’ve this problem and no reply from Steinberg :frowning: ! sure this is the last time I’m update before read user comments!

ok, where i find it on mac ?

Graphics seems lot faster. Refresh rate seems very good now! However the GPU load is to high for this type of application.

  1. Try booting in SAFE mode first with Cubase

To open the Safe Start Mode dialog, launch Cubase, and when the splash screen appears, hold down Ctrl/Cmd-Shift-Alt. Select DISABLE PROGRAM PREFERENCES, select Already registered when that screen shows up. See if your issue is gone or not. If it is gone and you will probably want to delete those prefs so Cubase starts with fresh preferences. NOTE: When you DELETE prefs ALL and ANY prefs you made will be gone.

  1. Cubase prefs are located at HD/USER/Library/Preferences/com.steinberg.cubase10v5.plist and also the Cubase folder there. IF you want to keep these in case deleting the prefs doesn’t fix your issue then COPY these two to another location so you can delete the current prefs after Cubase builds them. Trash the new ones and just drag your old ones back

***New Cubase update 10.5.10 is out BTW
e licecenser update as well !!

Same here with Native Instruments and more. What a mess. Looks like I go back to last version, where all those plugs blacklisted now, worked fine. …

What is Steinberg doing lately with plugins that cause so much blacklisting? It’s really weird. Maybe they are changing things behind the curtains to prepare for something bigger in the future (i.e. plugin sandboxing)?

I try in safe mode … crash Any time i load Arousor and mcdsp , and mcdsp have updated today all her plugin

I’m not sure if I have the same problem but 10.5.5 and 10.5.10 creches here on OSX if I open an Arturia Synth (ARP or Synclavier) and a Pro-Q3.
I create a new Project, create a Instrument Track, put the ARP 2600 into and as insert a Pro-Q3.
After a few minutes I get a beachball and the GUI freezes.
This is only if I open both plugin windows. If I open only one plugin window it is fine.

I say one thing if in cubase 10 work all plugin and in 10.5.10 not work the problem is cubase no plugin !!!

Same here!
Updated today 10.5.10 and it is an even bigger mess than before. Now Cubase crashes after some minutes when working (e.g. switching between different HALION Sonic sounds) with an instrument track. This is completely useless. Cubase 10.5 is definitely the worst “improvement” ever issued, at least on a Mac.

Back to Cubase 10…but wait: Did I not pay for 10.5??? What for?

I think Steinberg need to get their act together pretty soon.


Exactly. :blush:

I made another test.
One audio track.
Load two times the FabFilter Pro Q3 as insert and keep both Pro Q windows open.
Don’t tough anything wait a few minutes. Cubase will freeze. :frowning:

Same here no pb on windows but on osx
Waves Q10 + Fabfilter Q3 = Beachball and freeeeeze even in safe mode :confused:

If thoses freezes still happen with the update we are going to really hopefully very soon, we’ll need more system details and crash logs from those operating systems. I can only suggest submitting a ticket via MySteinberg or contacting your local support team with details.

I tested this exactly so and no probs. A whole project is running fine with 3 x PRO Q3 insertes on one track. I guess it is not a Cubase issue.

Note 1 here: I still use “Soundtoys Microshift” as insert 1 in my Controlroom, That was the trick a while ago on the crash issue.
If I don’t and try to open any former projects Cubase crashes while trying opening those projects. I hoped it would be solved but it is not and I assume it is one of my plugins (or W10) that causes this crash. I can live with this “solution” though.

Note 2 here: I had this exact problem with “Newfangle Elevate bundle” , opening more than 1 insert of this plugin caused a crash.
According to the manufacturer it is most likely an OpenGL problem within W10 and the plugin. I now can disable the OpenGL setting in that plugin and it works just fine.
So this could be a problem more often with other plugins that are build around OpenGL, so not a Cubase issue. More Windows related.