New User No sound in Dorico

No luck in getting playback sounds with a new project. I’'m using a Dell Latitude e6520 i5 500 gb hd and an up to date win7 os. The instruments show as loaded in the Halion player and when I click on a piano key the meter registers sound. I have asio4all loaded. What to do next?

My colleague Ulf recommends in this situation that you create a new project, add a player with a piano instrument, add a few notes, then save the project, zip it up, and attach it here. Ulf can then look at the audio engine setup data inside the project and suggest what might be going wrong.

Thanks Daniel, I hope this reveals something.
pianosoundtest.zip (196 KB)

Hi Richard,

thanks for the data. Looking at it, I can definitely see, that you are not getting any sound out, because the audio engine “doesn’t know where to send it to.”

Well, the engine detected only one audio device, namely “Speakers / Headphones (IDT H 1” device-id=“O|Generic Low Latency ASIO Driver|Speakers / Headphones (IDT H 1”.

You say that you have the asio4all. In Dorico under Edit > Device Setup, what items turn up in the drop downlist for ASIO Driver? What if you choose “Generic Low Latency ASIO Driver”? I would assume that will bring you sound.

Thanks for the reply. I have tried it both ways, asio4all v2 and generic. Neither produces sound, even though I see the meters reacting. I have enclosed some screen shots if that helps. I have Sib 7 on the same machine, would that affect anything?
audioengine2.jpg
audioengine.jpg

Actually, the screenshots do help. In the control panel of the Generic Low Latency Driver, have a look at the list of output ports, it’s completely empty. If you tick at the top the option “Allow ASIO host to take exclusive control…”, does then the list of ports show something? Also, do you have other audio applications running at the same time? Try to reboot and just start Dorico, open the control panel and see what ports do get listed.

Thanks Ulf:

Here’s what I get. Still no sound.
audioengine3.jpg

Okay, now with the Speaker/Headphone actually appearing in the list of output ports in the control panel, please again, create a new simple piano project and upload again.

Thanks Ulf, that did the trick and now I am excited to get to work learning Dorico.

Richard

Hi Richard,

glad to hear that it works now for you :slight_smile:

Cheers,
Ulf

Hello Ulf:

Sorry to be contacting you again about this but sound has disappeared again in existing projects. Odd thing is if I start a new solo piano project playback works, but not with existing projects that I’ve been working on. I’ve checked the control panel on the playback device and it looks just like it did when it worked. In the Halion UI if I hit a piano key for any of the instruments I’m using I can see the meter is working but still hear no sound. Any suggestions appreciated, thanks.

Richard

Try Play > Load Sounds for Unassigned Instruments to see if that helps.

That didn’t work. Oddly, when I open the Halion UI in an older progect I can see the instruments load, and in the mix panel, when I hold a key down the meter registers, but no sound. When I open the test project for piano solo it works fine. The settings in the control panel are set the same in both pieces. Really can’t figure this one out, so hopefully you may have some further suggestions?

Can you attach one of your existing projects that has no playback sound here, so I can take a look and see if I get any sound on my system?

Thanks Daniel, here it is.
clar trio.zip (1.04 MB)

Ulf and I had a similar arm-wrestling 2 weeks ago. NO SOUND on my system…until I went to the Task Manager and “end tasked” EVERY item in the list that could possible take exclusively control over my sound cart. Cortana and browsers also control the sound card.

My problem was “Windows Media Classic” that took control of the Sound Card preventing me from hearing anything.Then after a reboot, I had sound! Why I still don’t know.

I:

  1. right-clicked on speaker icon to the right om the Taskbar;
  2. click on “Playback Devices”;
  3. Double-click your listed “Playback device” populated in the list box…and the “Properties” dialogue will open up;
  4. select the “Advanced” tab on top; and
  5. de-select (remove tick mark) that is in the checkbox “Allow application to take exclusive control of this device”.

Also, just above this checkbox, is a grey drop-down list box. I find that changing the frequencies “refreshes” the sound card returning playback.

You can do this to every device listed in that Properties box.
When this setting is enabled, Dorico might not have access to your sound card as some OTHER device (like a movie player) has taken exclusive control of the sound card.

Hi Richard and Hans,

in this case I can see from the project data that no sound will come out, because the port mapping bit of information is missing. The port mapping is the information, to which port of the audio driver the output of the processed audio shall get sent to. In other words, the audio engine processes all the audio and then it sends it out into void, because it wasn’t told to send it to the audio device.

Now, the interesting part is, how can this (important) piece of information can get lost from your project file as it did work in the beginning? I assume that there is some bug somewhere in our software, but it must be special circumstances that invoke it, because otherwise we would hear much more often about it.
Richard, can you describe of how you worked with that project until the sound went away? Did you maybe carry it between computers, maybe even with different soundcards or operating systems? Please describe as much as you might recall.

In the meantime, I took your project and deleted the audio engine data from it. If you now open my new file and go to Play Mode and select the menu item Play > Apply Default Playback Template, all the necessary engine data shall get recreated and sound come out again. Please try.
clar trio new.zip (117 KB)

Thanks to both Hans and Ulf. I loaded the file sent by Ulf and followed the instructions but still no sound. I also went through running processes and closed firefox, also with no results. I also unchecked ‘allow applications to take exclusive control…’ to no avail. I do note that under the volume mixer Dorico does not show up under applications, but I don’t know if it was there or not when it was working properly.
Other than that I mostly use this computer only for Dorico. I have downloaded some windows updates but can’t think of anything else I might of changed, although I did try switching a project Halion Sonic and Symph Orch.
I also notice that in the file Ulf just sent, having clicked apply default playback, that the instruments loaded, but in mixer mode I no longer see the meters responding to activating one of the piano keys.

Richard,
could you please load my file, do the apply default template thing, save it and post it here again? Thanks.

I also notice that a recent solo piano ‘test’ I did a few days ago works plays back fine, but a previous piano project makes no sound.
clar trio3.zip (1.04 MB)