New video card caused Cubase Pro 8.5.20 to revert to 8.5.15?

Hey all,

I just switched over from an old VisionTek ATI Radeon Quad Monitor video card to a new Asus GeForce GTX 1070 Turbo and for some reason it broke my eLicense and caused my 64bit version of Cubase Pro 8.5.20 to revert back to 8.5.15. Actually, it caused all 64bit apps related to Cubase to revert to older versions. It didn’t do it to the 32bit versions though. I ended up having to re-license and re-install Cubase.

Anybody have any idea why this may have happened?


There is no 8.5.20 license, there is just 8.5 license.

That may be the case, but either way it broke my license. It gave me a license error and said something about my hardware configuration had changed when I tried to launch Cubase. Then it failed to launch just like it does when you don’t have the dongle connected. I had to go in to the eLicenser control center to repair it. I hit the maintenance task and it asked me if I wanted to repair my license. After I got everything fixed, I launched Cubase and the first thing I noticed was there was a different build date on it. I’ve never seen it do anything like that before and I’ve been using Cubase since 1999. ¯_(ツ)_/¯

The computer has probably reverted to a restore point and that’s why you are seeing old versions.
Today I changed my old GTX-670 for a GTX-1060, and Elicenser gave me an error. Taking it out and putting it back in, and running a maintenance on the dongle fixed it.
Those copy protections are fragile.

Yeah, must be what happened.