New VSL crashes Dorico

I recently moved to the ilok versions of VSL. Old dorico files do not recognise the new instruments / ensemble plugins. When I manually replace them it takes ages to load and save and dorico also appears to crash during playback sometimes.

Has anybody experienced similar things, is there a workaround?

The problem appears to be with VSL, not necessarily dorico (4.1)

iLok dongle or cloud?


Have you reported these crashes to the support team at VSL, and sent them your crash dumps?

Hi Daniel,
I already reported this crash to VSL, cause I’m having the same issue. I’m now waiting for a feedback.
Of course if someone else would like to report it, too, it will be much better to do it. :slight_smile:

Best wishes,

Have you tried opening the old Dorico file with the old eLicenser dongle plugged in? There was a bug when the iLok conversion first started where old VEP projects wouldn’t open correctly unless the old dongle was plugged in. After the file was resaved, then the dongle wasn’t necessary. Just wondering if something similar could be happening here and VSL is still somehow checking for it. If it works fine with the old dongle, see if you can save it, and then try again without it.

I did report to VSL, no answer yet. Other users at VSL seem to have similar problems of long loading times.
@FredGUnn: I had the dongle with the old license plugged in. I’ll try without it now.

Actually the problem is that the Dorico user interface freezes while saving, which takes 2 minutes with 3 VI instruments loaded (I use symphonic riot articulate maps, dorice save file is 5.6 mb). The dorico interface also freezes intermediately, then both VI ensemble and dorico have “no response” in the task manager.

When you save your Dorico project with Vienna Instruments loaded, Dorico has to ask the plug-ins to dump their state, which is then saved inside the project file. This state is pretty substantial in size, so it both takes a while and also makes your Dorico projects big.

This is one of the reasons why many people using VSL with Dorico choose to use Vienna Ensemble Pro to host the sounds, because you can then set VE Pro to run in “decoupled mode”, which means that when you save your project, VE Pro doesn’t send its state over to Dorico. You can then save the state of VE Pro itself separately.

Thank you for the suggestion. Unfortunately, the decouple option is not available in the vienna ensemble version provided with the ilok libraries
of VSL solo strings. In the pre-ilok versions of VSL, the save was only a few seconds, now it is minutes. The problem is known in the VSL forum
(it happens only when using large articulate maps or many instruments).

Also, the symphonic riot articulate maps do not (yet) work with the ilok VST3 versions. I will switch off autosave and wait for updates of
the articulate maps and (hopefully) of the VSL ilok software.


For the me the problem is at VSL. In Vienna Ensemble Pro wich I use there is the same long duration of saving and crashes. I thinh there is also a bigger Problem when using Symphonic Riot presets.

We have to be patient. I’m sure at VSL they work hard for solving all this problems.


I have reinstalled the old VSL libraries (Solo Strings / Solo Voices here). After inserting the folder where VSL installed the Version 6 instruments / instruments pro / ensemble VST2 plugins everything is back as before. The piano quartet which took 2-3 minutes to save with the ilok version now takes 5 seconds again.

Solved for me, waiting for VSL to deal with the save problem in their ilok version.

Thank’s for this information.
I will do the same

There was a new update to VEP a couple of days ago with a bunch of bug fixes. Just making sure you upgraded.


Thank you for the info. Since one cannot run ilok and eLicenser player / ensemble software concurrently I will stay with eLicenser until the save problem is solved.

and so will I. it’s really annoying that it’s not possible to try out new software without converting everything to iLok but I prefer to wait until as many of the bugs as possible are sorted.

just to clarify --there are no updates if you are still with eLicenser. My version from 23rd Nov 2021 is officially up to date.

1 Like

It is pity that VSL does not allow to run ilok and eLicenser versions concurrently so that one is able
to try whether new versions solve the problems. Dorico’s policy to allow running versions 3.5 and version 4 on the same machine is much more generous - thank you Steinberg!

I must say that it’s a major plus and relatively unusual feature that Dorico programme versions are compatible in both directions, provided obviously that you don’t use features (in most cases related to notation) specific only to a newer version. This has enabled me to work in and save projects in both v3.5 and 4, depending on which version was most suitable for exactly what I was trying to do.

… the same for me. I used V3.5 for tweaking the playback while v4 was not up to it.