newbee BFD2 midi issues

Hi all

I have a Roalnd td12KX drum kit and I can use this with BFD2 when BFD is in stand alone and although I’ve compared the vst interface with the standalone interface ( which match on every screen) I cannot get a midi signal using cubase. I have added BFD2 as a vst instrument and the midi channel loads it ok.

Im not familiar with MIDI and feel sure I need to set something up but having gone through the midi screens I cannot get a signal. I have loaded a kit and I can hear the drum sounds using a mouse but nothing when I hit a drum pad…oh, and I have attached the MIDI cable to my sound card ok as it works in standalone.

can anybody help me please…cheers

Slimvillan

Cubase SL2, BFD2 ( latest patch), TD12 KX, M-Audio 192 sound card
Windows 7 Pro, Intel quad 4 chip
12Gb RAM

Device Setup-MIDI Port Config., make sure your device is listed and is the only one set to show and the All MIDI is unchecked then select it as the input of the MIDI track. The Monitor button on the track needs to be enabled to hear realtime play.

thank you, Ill try it and let youknow how I got on…

Slimvillan

Hi Mashedmitten

I think Ive done as you asked, I went to to device setup and found under ‘devices’ All Midi Inputs an entry called DeltaAP Midi and under the Active column it says No,
Also listed under Device Setup was Default Midi Ports and in the Set up tab Ive BFD2 as Midi input and Output. In the Add/Remove tab of both All Midi Inputs and Default Midi ports i am unable to remove any of the items listed. I get an error message ‘This device ‘Default Midi Ports’ cannot be removed’. When you say ‘make sure your device is listed and is the only one set to show’ do you mean its the only option ticked. BFD2 is the only option ticked. The other options I could choose from are some Absynth Surround vst’s the DeltaAP Midi, all MIDI inputs and All MIDI Inputs ( which has no tick next to it either, only BFD2).

On the Midi track BFD2 is set to IN and OUT. Cnannel ANY map = GM Map. I have tried altering the In and OUT to All midi Input as in and BFD2 as out and viceversa but this hasn’t worked either.

Slimvillan

You want to choose the MIDI port you’re using as the input of the MIDI track, not BFD. You don’t want to remove anything in MIDI Port Config., just make sure the device you’re using is the only one checked. Don’t forget the monitor button.

Hi

Im really sorry to appear such a dimwit…

Under Devices, Device Setup, Default MIDI Ports ( in the setup tap ) I have the following option for Midi Input

Not Connected
BFD2
Absynth4 Surround 1 to 4
Delta AP Midi and
All Midi Ports

Under the Midi Ouput it exactly the same plus…

Microsoft Midi Mapper (Emulated) and
Microsoft GS Wavetable Synth ( Emulated)

Which do I need?

Also on the Midi channel the options for In and OUT are the same…although Ive tried various different configurations I cannot recieve a midi message

Also within BFD 2 if I click on, say, the snare, I get a message telling Cubase is waiting for a midi signal when I have the Midi Note Learn option lit. By the way the monitor icon is lit ( a kind of dark orange colour)

Slimvillan

I understand this is very basic stuff and many facets of cubase and bfd Ive figured out alone but Im really stumped on this, thanks for your help

What is the controller connected to? I’m guessing the Delta card so you’d want that as the input.

Here’s a screenshot of my setup using a Firebox as the MIDI interface.
MIDI Setup.JPG

…It lives…

I had various options like pan and vol not set to off but with delta AP midi as IN and BFD2 as out I have a signal


Thank you so much for your help, this was driving me nuts and I knew it must be somethying very simple…you’re a star, thanks a million


Leigh