Newbie Audio and USB setup problems. Worked before, suddenly doesn’t!

Hi All

I’m a Cubase newbie (Cubase 12 Pro - Win10 on PC and Win11 on laptop). And I’m getting pretty frustrated with it.

Getting Cubase all set up and working was a lot more difficult than I ever would have expected. For example, having to install a non-Steinberg freeware ASIO driver (ASIO4ALL) in order to get my external synths working via USB. That seemed a bit weird - having the whole system potentially vulnerable to third party freeware - or not being able to use external synths via USB, just doesn’t seem right. Maybe there’s a better solution (please post if so), but until now I’ve had some success with ASIO4ALL.

I say “some” success because I got it all going nicely, for about three weeks and thought I was getting somewhere, then suddenly, two days ago, no audio came through my interface (UR22C). Also, my Korg Kronos X, came up as “Missing Port”. Then my UR22C came up as Missing Port. I never changed anything. Then, even if I started a blank project, I couldn’t get any audio out of my UR22C. I removed all drivers (Korg, YamahaSteinberg, ASIO4ALL), then reinstalled everything one by one, but it still didn’t work properly. Eg under Output Bus, it used to show UR22C L and UR22C R, but now has a list of “Wave000xxxx” bunch of numbers instead. I can get audio out of my UR22C again, but only using SW Instruments or samples within Cubase but I can’t get audio from my synths any more and therefore any projects that used them don’t work anymore. It’s driving me nuts. I want to get on with making music but I’m wasting hours solving ridiculous problems that just seem to keep coming out of nowhere. Maybe it was a Windows update that screwed me this time. Who knows? I just want to fix it and get back to making music.

If anyone has encountered this or similar, please post a “recipe” that I can follow to get back in action.


Further to the above I have just spent all morning on this, to no avail. I completely removed all associated drivers and software (except Cubase itself). I reset the USB ports. Restart. Installed latest Yamaha USB driver. Installed latest Tools for URC. Tested it on a blank project. It worked (sound finally came out via the UR22C). Connected my Yamaha MX49 synth (via USB). It worked as a MIDI controller to control Halion. Then I installed ASIO4ALL again. Set all that up in Studio Settings and Audio Setup. Everything appeared correctly. (All the appropriate Ins and Outs, ports etc showed up as active.) But… no audio coming out of the UR22 again. And no MIDI signal coming in from the Yamaha MX49 anymore. Seems it just doesn’t like ASIO4ALL anymore. I have a Focusrite Audio Interface. I will try that instead, just in case my UR22 is the issue.


If you want to get sound out of UR22, use the IR22 driver, not ASIO4ALL, please.

Please, describe, what would you like to get. Also describe your connections (cables) and your settings in Cubase (selected ASIO driver, Audio Connections > Outputs settings).

Hi Martin

Thanks for responding so quickly. It was you who I learned about ASIO4ALL from, in order to use my synths via USB and have the Stereo Out go to my UR22C. (I learned it from this post: Audio over USB external gear)

My setup is fairly simple:

Cubase 12 Pro on Windows10
Yamaha MX49 external synth
Korg Kronos X external synth

All three USB devices are connected to their own USB port on my PC (no hub).

I just want to be able to keep my synths connected via USB and use them in Cubase projects, not just as MIDI controllers, but for audio as well.

Like I mentioned earlier, I was doing this quite successfully with ASIO4ALL until something happened and now I can’t.

If I were to start over, how would I best go about it?



Then merge multiple Audio Devices (your synths + UR22) to one ASIO Driver by using ASIO4ALL. In Cubase use the ASIO4ALL then.

Hi Martin

That’s what I have been doing. Until a few days ago it worked very well but suddenly all sorts of stuff started happening which stopped me from being able to use them. Things like, missing port, devices showing as inactive. I since removed the software and drivers for my external devices (UR22C, MX49 synth, Kronos X synth, ASIO4ALL) and reinstalled them one by one. I had some success, in that my UR22C works using the Yamaha Steinberg ASIO driver, and I can use my synths as MIDI controllers, but in order to use the audio from my synths over USB, I have to, of course, use ASIO4ALL and when I use that, everything turns to custard again. I will try to upload screen shots of my setting, just in case you, or anyone else, spots a setting that is messing me up.


Could you attach the screenshot of the ASIO4ALL Control Panel, please?

Please see screenshots, as requested

ASIO4ALL Control Panel:

Audio Connections, Inputs:

Audio Connections, Outputs:

Of interest, I opened a project that I had made to get Cubase set up and start learning how to use it, and it hung during loading. I had to use End Task to kill it. Then Cubase wouldn’t load at all, so I restarted my PC. Then I opened an earlier version of my “Cubase Learning” Project, and I re-selected all the devices in the ASIO4ALL Control Panel and under Inputs and Outputs in Audio Connections (I had removed and reinstalled all audio drivers and software, remember). Once I had selected everything again, it worked! I can hear my synth’s audio over USB once again.

USB Audio working Outputting MIDI to my KronosX and monitoring the audio input via USB:

I have no idea what caused it to stop working. I tried everything I could think of. Even removing and reinstalling the drivers and software for my external devices didn’t resolve it, at first. Somehow today it decided to work again.

Maybe it has something to do with the sequence that I switch my devices on and/or plug them in and load Cubase. Whatever it is, I have noted the sequence that worked today and I will stick with that. Hopefully no more issues…

1 Like

Unfortunately the ugly problem has returned. I noticed there was a Windows update a few days ago (Windows update is my prime suspect). I tried to use ASIO4ALL to record some audio over USB from my external Yamaha MX49 but, like before, it just won’t comply anymore. So annoying!

I’ve resorted to sticking with the Yamaha Steinberg ASIO driver and listening to my synths via an external mixer. At least the MIDI transmits via USB. I just have to record each synth part one by one over analogue inputs to my UR22C. A compromise to convert digital to analogue then back to digital again but it’s the only way for me at the moment, it seems.

Unless I can figure out a step by step solution each time this happens, that doesn’t take hours, with multiple restarts etc, it will unfortunately be goodbye ASIO4ALL and goodbye audio over USB from my external synths.