Newbie Can't Make MIDI keyboard work

Alesis Qmini keyboard, works just fine with Cubasis. Works sporadically fine with Cubase 12 on my other computer (Win11), but often behaved the same way it is now behaving on my new Lenovo Ideapad 5, AMD Ryzen 5 6600, Win 11.

Immediately after startup, creating a new instrument armed track with Halion as VST, the keyboard will sometimes work for up to a minute, at which point the last notes I played will go on sounding and no new notes can be input. A midi reset stops the old notes, but the keyboard will produce no new notes. Meanwhile the onscreen keyboard in Halion continues to work just fine.

I’ve tried checking and unchecking many boxes in Studio Setup->MIDI Port Setup, including those for “DirectMusic” and “WinRT MIDI”, and checking and unchecking many boxes in the MIDI Port Setup Section above, where the Qmini shows once or many times depending on which boxes are checked in the lower section. Since I don’t understand what I’m doing, these actions have been rather random and had no effect on the problem.

I’ve also tried moving the files ignoreportfilter and enableemulated into the main Cubase directory, which I think may have increased the number of entries I see in the above window, but also had no effect on the problem.

All I wanna do is just used the keyboard as a keyboard (i,e, not trying to control Cubase functions with it), but am kind of wondering if I’ll ever be able to actually play a VST with it in Cubase, or if I’ll be stuck forever with only a piano roll or having to import midi parts from Cubasis.

Help? Thanks! Jon

Well that’s interesting. I downloaded a Windows app called pianotime. Same behavior. Get a few dozen notes out, then nothing, while the onscreen keyboard continues to work.

And I checked and Qmini continues to work just fine in Cubasis.

This seems to be pointing at either the device driver for Windows or however the heck Windows gets MIDI messages to waiting software. Since I’m a Linux guy, my ignorance is profound, so I’m still looking for help if anyone can.


It does sound as if your controller is the culprit. Do you have access to any other USB MIDI keyboard you can test with?
Have you been in contact with Alesis about this issue?

It was the cable! In fact the very cable that Alesis supplied with the keyboard.

I would have tried a different cable earlier, but don’t have USB A → Mini USB B cables lying around. What’s up with MIDI controllers and USB B??? Anyhow…

Finally realized a radio I have uses that configuration for charging. Doubted that the cheap skinny cable would work for data, but tried it anyway and it works. Perfectly, every time. No freezes, no skips.

Lesson learned. Anyone have a recommendation for USB A → USB B mini cables that are bulletproof?