Newbie Help Recording issue

Hi. I am new to home recording but have some basic understand of recoding practices of old. I am recording a telecaster guitar through a Steinberg UR22 Mk 11 in to a 2011 iMac via USB. I lay down a drum loop and then try and record the guitar via input 2 hi-z but the tracks seem to be chained or spilling into each other so it records the drum loop again. If I leave the metronome on during recording it picks that up as well. It happens in Garageband too, where I get awful feedback from the guitar. I obviously have a stetting wrong somewhere. I have tried turning the monitor speakers off and just using headphones but still the same issue.
Any advice most welcome as it’s driving me mad!
thank you

It seems strongly that you have the loopback function activated. Turn it off and see if this was the problem.

Thank you. I checked the loopback function but it is turned off/unchecked. I had another go at a new project but same thing. Best. Karl

The nearest google answers I could find was that i had the output settings being channelled back through the inputs? Not sure how to resolve that.

Hello could you post screenshots to show better your situation?
For example screenshots of your tracks setup:
and audio connections (accessible by pressing F4)

I tried and sorry to be so thick but there is a message saying ‘you can’t embed media in a post’.

If you have an app that takes screen captures (for example like the free Greenshot) you can grab parts or the entire screen then click copy and then do CTRL+V directly in the forum (in this way you do not even have to save them on your disk)

thanks both your for your help - it was much appreciated. I slept on it and then revisited the problem today. I found 2 application source windows for the UR22 and the loopback was on within the Applications file icon but showing off if I went in via system preferences ‘sound’. I turned it off and also updated the firmware for the UR22 Mii and it seems to have worked.
Again, thank you…

1 Like

Glad you solved your issue. Thanks for the update!