newbie - help with midi/vst routing issues ?

greetings !

i’m test-driving cubase 8 elements trial edition, and i’m running into some problems.

i’m creating an orchestral template containing 6 instances of kontakt [so 6 ‘instrument’ tracks], 42 midi tracks and 24 audio outs. routing from the midi tracks to the instrument tracks was easy enough, and setting up a master ‘group channel’ was too [i’m guessing a ‘group channel’ is the cubase name for ‘bus’], but i can’t figure out how to get kontakt’s outputs connected to the host audio track inputs. i’d like to route each kontakt output [i’ve got from 3-6 outputs on each kontakt] to one of the audio tracks so i can apply effects, add sends, etc., if i need to. how can i do this ?

when i start cubase, it resets one of the stereo input channels on my audio interface, setting all parameters for that channel to zero. looking into the ‘VST Connections - Inputs’ window, i see that this channel is the one it’s configured as its input channel by default. same thing happens when i load a vst connections preset. for example, if i’ve defined all input channels for my audio interface [rather than just the default one, above], then cubase resets ALL inputs to zero. how can i make it NOT do that? i.e., i want it to leave all the inputs ALONE, just as i had them.

when i create a vst setup and save it as a preset, my connections are in order. when i reload it, they aren’t ; for example, one of the stereo connections appears first, but i had it near the end. how can i tell cubase i want them to stay in the order i put them in ?

whenever i make a routing change [e.g., vst connections window, or track inspector bus assignment] it takes about 6 seconds for cubase to make the change. the program doesn’t respond to any controls during this time. is this ‘normal’ ?

the vst instruments / audio bay appears on the far right of the display. is there a way i can move it to the far left ?

thanks much for your input !


If you have Kontakt loaded as a ‘Rack Instrument’ go to the ‘Vst Instruments’ window right-click the plug-in and choose ‘Activate Outputs’ in the menu. If you are using ‘Track Instruments’ it’s easier to add them in the ‘Inspector’ panel.

And welcome aboard, dave007.

thanks, krisp !

ok, i’ve selected several of the outputs to be activated [there are about 64 of them…]. i’ve selected the first 3 or 4 for a couple of the instruments. however, when i try to look for them as inputs on the audio tracks, i still have only my hardware inputs available.

Hi Dave,

this is working different in Cubase then in other DAWs: you do not select the outputs of the VSTi as input of an audio track. Instead the outputs you activated already are automatically showing up in MixConsole as well as in the VST instruments folder track in the track list on the project page.

The VSTi rack can currently not be switched to the left side atm.

Best regards,

ah, ok ! thanks. actually, this makes good sense. :slight_smile:

do you have any idea how i can tell cubase to stop resetting the input channels of my audio interface to zero any time i load a connections preset or change my preferences ?

i’m sorry, i’m still having problems with this.

i have 4 outs configured in kontakt -

  • violin
  • viola
  • cello
  • bass

i enabled these outputs correctly in cubase, but when i looked for them in the mix console, they didn’t appear. [see image below]

i then disabled all the hardware busses. strangely, the vst busses then started appearing in the space between the inputs and the outputs. [see the arrows in the image below]

notice that the horizontal scroller is small and moved to the far right. it doesn’t scroll the whole display ; every hardware bus stays exactly where it was, only the vst’s are scrolled ‘behind’ the hardware busses, so the vst busses never appear unless i hide the hardware inputs and outputs. i’ve searched preferences for something to change this but can’t find anything. what preference setting do i need to change so the scroller will scroll everything together, and not hide the vst busses behind the hardware busses ?

so now i can see the busses, but there’s another problem. when i click on kontakt’s internal piano keys, i can see that the instruments are being routed to their korrect kontakt outputs. however, they’re going to the wrong cubase busses ; they’re one off. when i play a violin sound, output on kontakt bus 1, the sound comes out my audio mains. a viola sound [kontakt output 2] comes out the first cubase bus, for violins ; cello comes out the viola bus, bass comes out the cello bus.

then i noticed that when i unhide the instrument’s main global output, i can see the violin sound coming out on it. so the first kontakt output bus is actually being routed to cubase’s idea of the ‘main’ out, the second instrument to cubase’s first instrument out, the third to the second, and so on. i thought i could work around this by just changing the name of the main instrument out in the mixing console to ‘violin’, but that also changed the name of the entire kontakt vst in the track view, which is ridiculous, since this kontakt is playing more than just violins. how can i set up cubase so that the vst name in the track view is accurate [i.e., ‘strings’], and have kontakt’s bus outputs sent to appropriate cubase individual output busses, w/their correct names too ?

thanks once again very much for your help !

no way to have the vst outputs show up w/the other outputs ?
no way to name the output channels appropriately ?