Newbie String Quartet Observations (1.0.10)

I bought Dorico to get a heads-up on workflow (it won’t be my primary program until chord symbols and 1st and 2nd endings are implemented). I entered two string quartet arrangements. I did this by creating a flow, entering the first quartet, and then creating a second flow for the next quartet.

I’ve found a few things happening that seem a little odd to me, and so I wanted to note them. In some cases, they may be bugs, while in others, they may be user error or system related somehow. I’d love to understand what is happening with them.

  1. When entering notes, the note sounds upon entry. It also sounds if I then select another duration for the next note I intend to input. Is this supposed to happen? It’s kind of annoying. I’d prefer to hear the note only upon input. So, If I put in a half note A, for instance and then select quarter note to insert a Bb, I don’t want to hear the A repeat, just the Bb when I enter it.

  2. When I enter notes, the score doesn’t move to show where I’m up to, so I am not seeing the notes as they appear. Is this supposed to be this way? Is there another view, other than the default that I should be choosing? I’m using the full page view that appears when I create the flow.

  3. When I am inputting or selecting notes, the score occasionally jumps to another part of the score. For instance, I’ve started a second flow, entered a few measures into the violin and selected them so I can copy them. When I select them, the score jumps to the middle of the first flow. I can’t isolate everything causing it to do this, but it always happens when I hit the end of a line and the music should move to the next system. Instead of redrawing the screen there, it puts me back earlier in the piece, or even in an earlier flow. This happened when I only had one flow also, with the screen jumping to earlier in the piece, rather than to where the note entry was happening.

  4. Playback is choppy, with dropouts/stutters.

  5. In Write mode, when I click on a note value after entering it to deselect it, nothing happens. To be able to select a few notes to add slurs without changing their values, I need to leave Write mode, and then when I re-enter it, I am able to click on the not value on the left-hand side to deselect it.

  6. When I select a note, say in the first violin, and right arrow through the rest of the system to hear the notes while proofreading the original paper score, it jumps to a different instrument at the end of the line, rather than continuing the first violin part. Is this expected behavior? I’d much prefer if I could “scrub” through the entire part that way instead of having to hear some viola notes, find the place I want to be, click back in etc. It’s very distracting.

I’d love to know if I’m doing something wrong, or if these are bugs, and what workarounds there might be. I’m on a Mac running OS X El Capitan 10.11.6

Thanks!

  1. The note will no longer sound more than once in the forthcoming 1.0.20 update.

  2. In general you should find that the score moves to bring the caret into view if you end up inputting towards the edge of the screen. I’m not sure what might be going on that this isn’t happening on your system. Do you have an especially small display, or are you very zoomed in, or very zoomed out?

  3. I guess this sounds related to the previous problem, but this is also not something that we are seeing in general.

  4. You could try adjusting the buffer size in the Device Control Panel dialog, accessed from Edit > Device Setup.

  5. This is working as intended: if the caret is visible and you’re in note input mode, then you can’t deselect a note value in the panel; likewise if you’re outside of note input, then the panel will reflect the selected duration.

  6. There is a bug that can cause the selection to hop to another staff when you cross the end of the system, which will be fixed in the forthcoming 1.0.20 update.

Thank you, Daniel.

Re #'s 1 & 6, I’m glad to hear these bugs are already sorted in the forthcoming update.

Re #2 and #3, I am on a very large screen iMac. It’s not when it reaches the end of the screen, but the end of the line. I’m on the default settings. Not zoomed in or out… I’ll restart and see if a0 that helps or b) I can further ID when this is happening.

Re #4, after trying different settings, I’ve maxed out the buffer and it is better but it still dropped out once. Maybe a relaunch would help. Will try that.

Re #5, I didn’t think so, but that may well be what’s happening. I’ll check and confirm.

Thanks again for the quick support. I’m really excited about Dorico.

OK, I’ve played around with this a bit, and it’s often happening when I reach the end of a line, but always happening when I reach the end of the page. I took a quick video to illustrate what’s happening. You can see it here: https://www.dropbox.com/s/cr4z31k5z41pxiv/Video%20Dec%2016%2C%2012%2038%2048%20AM.mov?dl=0

I’m also noting that there are occasional spots in the score where the slurs are crossing accidentals (specifically flats). Did you want to see specifics, or is this something you’re aware of that can happen. My impression was that this wasn’t supposed to be able to happen in Dorico. These are not complex parts, so shouldn’t be giving the program a hard time with collision avoidance, I’d think. If you’d like to see the file, I can send it to you, or upload a pic.

Thanks!

Just to confirm what Binkeys said: I have the #2 and #3 behaviour as well… (iMac and MBP on El Capitan)

Thanks for uploading the video. It looks like it might be a problem with moving the score view only when the View > Pages > Single Pages Vertically is chosen. As a workaround for the time being, try using one of the other page arrangements from that menu. We’ll look into this and try to sort it out.

As for the problem with slurs crossing the stems of flats, this is actually intentional and often done in traditional engraving, but there are options to disable it on the Slurs page of Engraving Options if you don’t like it.

Good to know about the slurs/accidentals being desired behavior and also that there’s an option to avoid it globally if desired. It was super easy to find once I knew what I was looking for. I really like how you’ve modeled the menu on “Behind Bars” so I can look for the image that matches what I’m looking for, instead of having to guess what things mean.

Hoping that bug gets squashed soon. I kinda like the vertical view. Thanks for letting me know that there is a workaround.