Newly installed Ilok plugins not loading in old projects?

Has anyone had this issue. I installed the demos of the Kush Omega transformer plugins that use Ilok authentication a few weeks ago and they would pretty much only work in new projects I made after installing and I’ve just got the Eventide H910 demo installed and once again it won’t load in ‘open’ projects… Cubase just stalls for a second as if loading and then resumes but no plugin has loaded…

Has anyone else experienced this?

I’m on 32bit 8.5.0 W7 64bit

Thanks. :slight_smile:

I have exactly the same problem with Eventide H910 (full version) on my system. Cubase sees the plugin, it’s been scanned in the plugins directory. It shows up in the plugin list.
But when I try and load the plugin (H910 Harmoniser or H910 Dual Harmoniser) it pauses in Cubase and then nothing happens. The plugin doesn’t load :frowning:

The plug is registered with my iLok 2 dongle and also at Eventide.

I have uninstalled and reinstalled the plugin, but it still doesn’t work.
Very frustrating to have paid for the full version to find it doesn’t work! This is the only plugin I have that has a bug. Everything else is rock sold on my system.

I have found no answer anywhere on the net, and am still waiting for a working solution from Eventide.

32bit 8.5.0 W7 64bit 12GB

32bit Cubase ?
Does it work in the 64bit version ?

Yes it works in the 64 bit version of Cubase (which I don’t use as part of my workflow).

Today I heard back from Eventide Support and they suggested installing JUST the 32 bit version of the plugin, which I tried and also doesn’t work.
I mentioned to Eventide support that the install program for the H910 programs is appalling, as Windows only registers the C+ component and nothing else.
So when you try and uninstall the H910 plugin - you can’t, because it’s not listed in the Control Panel Add/Remove Programs List! Very sloppy design.
At the moment I have paid for a plugin that’s given me 1) Headaches, 2) Waste of time, and 3) Not much joy.

I’m really hoping for a fix on this. I’m waiting for the next reply from Eventide. Fingers crossed!

Did you ever get a workable solution from Eventide? I have the exact same issue

Hello everyone, I have been in touch with Eventide about this.

The issue has been fixed in their latest build (still to be released to the public, it seems), I’m told several users confirmed it’s fine now. The issue was apparently due to a specific iLok wrapper used for that build.


Hi again,

I’ve been informed that the new builds are available for download on the Eventide website.

Those who had this problem, please download and install it, it should resolve the issue completely.

Thank you!