Next part via MIDI does not work anymore in VST Live 2

Hello! In VST Live 1 I automatically switched to the next part via MIDI - I set up the MIDI controller in Actions and Shortcuts/Project/Next Part.
Manually Switching to the next part by pressing a pedal on my MIDI controller worked perfectly even while playing back audio tracks, which exactly is what I need.

In VST Live 2 this does not work anymore while playing back audio tracks.
And it makes no difference whether I activate loop mode or not. To define parts with specified length is not an option for my show.

During a show for me it is mandatory to be able to switch to the next part using a pedal from my MIDI controller, while a backing track is running.

Please advice how this can be fixed.
Thank you!

Works fine here. Make sure that in “Actions and Shortcuts”, the range of Data 2 is set reasonably (usually, just 0 to 127). If for instance you “Learn” with a Note On message, it will only react to the “learned” velocity (Data 2), and if your button is sensitive it will rarely hit that exact value, so adjust the range accordingly.
Also take into account that while transport is running, only Parts without a trigger time can be selected. Otherwise, the system will locate to the Part whose position and range lies within the cursor position. You can delete Part Triggers in the “Song/Song Part Triggers” list.

Thank you for the quick response!

I made sure that Data 2 is reasonable. I am using a pedal switch and not a key on my MIDI keyboard. Switching with the pedal works perfectly as long as the app is in “Stop” mode.

However, it does not work anymore when starting play back.

I will give you more details about the malfunction. When I am playing back the first part the screen will briefly flicker and the app will stay on the first part. When I select one of the subsequent parts and then start playback, after pressing the pedal the app will jump back to the first part instead of selecting the next part.

One more information - Using the down key on my computer keyboard works fine to select the next part, even when in play mode. So to me it seems to be a problem with the MIDI implementation.

And again, it also works perfectly in VST Live Pro 1, no matter if the App is in Stop or Play mode. (Using VST Live 1 saves my life, as otherwise I would not know how to play my shows)

I am aware that I cannot manually switch parts with trigger time. All parts I want to switch do not have trigger time (except the first part, which has got by definition 0001.1.1, of course). I attach a screen shot of the Actions and Shortcuts page)

What can we do to fix the problem? Would it be helpful, if I send the vlprj file?

Can you just put here a screenshot what the MIDI Monitor captures? We could compare received and set CC values with

I also have the same problem, I opened a new topic, I apologize, I didn’t know there was this one which represents the same problem as me

how do you do this?

select and minus button

The song and the parts:

MIDI Monitor before pressing the pedal
MIDI-Monitor_Before

MIDI Monitor after pressing the pedal
MIDI-Monitor_Afterjpg

I screen captured some test cases showing the malfunction via OBS for your information. See link.

Hope that helps

Hey! Seems FLEXLOOP is not active! Above song list and find in the middle. Turn it “ON” / “ACTIVE” then check again

I do not need to loop the parts. Nevertheless I made some tests with FLEXLOOP on.

The results are even worse. Not only that VST Live does not switch to the next part, it starts to loop the active part after completing the next bar or so, although I set the loop for this part to OFF. (See screenshot)

To make these tests even more complete, I used different keyboards (Kurzweil PC3 K8, Korg Kronos, Studiologic SL88) and differnt MIDI CC messages. None of them worked.

So, after all these tests I have to say, that it is not at all possible for me to make this functionality to work as it is intended to.

Dear Steinberg team - please run some tests on your side, I hope you will see similar test results as I do and find the reason for this behaviour.

Thank you!

It’s a simple bug.

  1. Start a new project
  2. Create a 2nd part in Song 1.
  3. Hit Play
  4. Backword/Forward pedals no longer work.
    I’m using 2.0.10.118. If I actually had to use parts, I’d be screwed. I was just trying to use the metronome during practice.

Download plz 2.0.23 and give a try with :slight_smile:

No until all the multi-processor bugs are resolved. I can’t risk anything this week.

Yes indeed- It is a bug. At least this is the only explanation I have at the moment…

Where can I get it? Download assistant offers 2.0.20 as the latest version, which I have installed already, of course

Okay, maybe better to wait tomorrow evening. Developers of VL used to post new pre-releases here in the forum on Fridays evening

You can just leave audio MP off in preferences and you will not be affected by related bugs, i used 2.0.23 in last rehearsals without troubles (except a lyric related bug that will be fixed in tomorrow release).
Ciao!

1 Like

vstlive.net

Just switch Multiprocessing off.