Nexus 2 arp out of sync with other vsts

SO Im having a problem with my arp syncing up with my Eastwest plugins or rather the timing of of both of them seem to be off when i try som staccato notes with my violin patch layered on the arp. I wondering if there is an option to sync nexus 2 vst plugin with the play plugin so that they are not out of sync.

I have cubase 6 with windows 7 hom prem 16 gb ram several 7200 rpm disks and Phenom II amd quad core processor.


If you are using the East West orchestral samples, they seem to be delayed a little, so what I usually do to get them to hit ON the beat is to use the timing “track delay” function slider (a little clock on the upper left of the MIDI panel). But instead of delaying the MIDI track move the slider to the left and it will bring back the timing to correctly match your other Nexus 2 Arp.

Let me know if this helps you at all.


I’m not sure where to find that option or what window im supposed to look in?

It is in the arrange window. When you have a MIDI track selected, on the upper left hand corner there is a box where you can change the parameters. In that box there is a little clock icon with a slider. Just move it to the left a little, and it should make the East West MIDI trigger sooner.

Sorry but i still cant seem to find it. I’m new to cubase 6 so im not sure where everything is.

I believe that there is an offset control in the info line so you could just shift sections too

Found it thanks guys! gonna give a try on the project soon. Heres a video of me working on the projects. I stream myself working sometimes for my friends.

Nice - I enjoy watching others work… BTW nice sword… is that the t12 ? :smiley: