NI B4 Plugin with Cubase 9

Cubase 9 won’t recognize NI B4 plugin (because it’s 32 bit). Is there a way to make Cubase see it or…do I need to get a different virtual organ? If so…can somebody recommend one to me? I’ve searched all over the web and can’t find one.

You can use jBridge or 32 Lives to run 32 bit plugins in Cubase 9 and 9.5. But I strongly recommend using a 64 bit alternative, they’ll be far more reliable.

Give VB3 and Blue3 a try. Halion Sonic 3 also has a pretty good organ emulation, and includes other vintage keyboards and other potentially useful instruments, which might make it a better bang for the buck depending on what kind of music you make.

Chrikeys doesn’t mention his (or her) platform…but I can tell you, on a Mac, B4II runs without issue in Cubase 9.5 using either JBridge or 32Lives. Also: VB3 (which is 32bit only on the Mac) runs without issues using either JBridge or 32Lives. No crashes, no excessive CPU usage. Having used both of these, as well as HALion’s organ, all I can say is B4II has its own special character that is something I have always liked and prefer in certain circumstances. If you love the sound of the B4II and you’re on a Mac, then look into JBridge or 32Lives. 32Lives is more expensive than JBridge…but far less fiddly setting up.

B4II with jBridge has been working just fine for some time here too.

On my PC, B4 doesn’t run even with JBridge. I’ve tried it in to different computers and in none of them works.

It’s really a pity because in my opinion B4 (B4II) sounds infinite better and more faithful to the original B3, than VB3, which has a much thinner sound and a much poorer interface. I really regret not being able to use B4.

Have you tried finding out why jBridge does not work on your machine(s)? Your computer in your signature seem to bepretty ‘normal’ for a DAW. jBridge here has worked fine going back to my Core2 Quad Q6600 machine.

I haven’t seen your post. Thank you, Mauri.

I’ve been fighting against my two computers and JBridge works in one of them. Unfortunately, is the one at home (Intel Core i7-4770S processor and 16 GB) but not at the studio. Anyway, I can render at home the MIDI files to audio and use the B4 again. :smiley:

Can’t find why it doesn’t work at the studio. I receive a message that the 64 bits file has not been created.

Hi, Juanjo,

Maybe you could compare the jBridge file locations on both your computers? One or more files on the machine which gives you that error message about the 64 bit file may be in a wrong location.



NI B4 working fine here on jBridge with CB9.5.1.

I have a slight niggle with it. When I open a new instance of B4, I get no audio at all from the B4 until I touch one of the rotary knobs on the B4 interface - Reverb, Drive of Bank - then all is fine for the rest of that session.

If I record the B4 as midi, closing and reopening the project works fine and the B4 plays OK.

It’s only on the first new B4 track addition that this problem exhibits itself.

Never been able to get to the bottom of this, including filing a bug report and talking to the jBridge author about it.

I still use B4 simply because it sounds so good, and I also have the Bohm hardware controller for it too.


Unfortunately both seem to be in similar locations.

The original 32 bits B4 II.dll files are in both computers in: C:\Program Files (x86)\VSTPlugIns.

I’ve also created in both computers a new folder called VSTPluginsBridged in C:\Program Files (x86)\VSTPlugIns Bridged
In the home computer two files have been created inside the new folder: B4 II.64.dll and B4 II.64.txt.

I’m on travel now but next week I’ll try again in the studio computer. There is not an apparent reason for this issue.

B4 was the first VSTi I bought in 2000, it sounded awesome then and it still does. Never understood why NI stopped developing it. Originally you could use the Leslie as a standalone effect too, and that was brilliant, but it broke ages ago and never got mended - shame.

You can run those old plugins if you run Cubase as an administrator.

Do you mean without a third party bridge?

Nope, it’s with jBridge.

This is no longer required with the current version

Well, when I try to run jBridge 1.75 on win 10 pro 64 and not as admin the plugin GUIs are white.

isn’t battery 64bit?

Edit: I’m stupid, you’re all talking about the organ keyboard plug-in, sorry.

“I’m stupid”, you’re not alone, feel right at home :wink:!

haha Been there done that, I bought the mug, saw the movie … and will do it again! :blush: :laughing: