NI compressor plugins crashing Wavelab 9.5.20

Some Native Instruments plugins are crashing Wavelab. When I load them to master section as soon as I start playback I get an error message (attached picture) Wavelab freezes and I have to kill it in task manager.


Happens with Solid Bus Compressor, Solid Bus Dynamics, Supercharger, Vari Comp.

EQ plugins and reverbs seems to work fine.

All of the plugins work fine in Cubase 9.5

Is it a 64 bit processing plugin (do you see the 64 F tag?)
Try to limit processing to 32 bit (File > Preferences > Global > Audio)

Is it a 64 bit processing plugin (do you see the 64 F tag?)

No, it’s not.

Try to limit processing to 32 bit (File > Preferences > Global > Audio)

Just tried this. Still the same.

I would need to see a crash dump, to have some hint.

Hi PG,

Could you give me some instructions how to generate a crash dump. I tried to enable logging but there’s not much information in the log file and no crash dump being generated.

MainLog.txt

[2018/03/17 21:49:25] INFO: [     0.360 / 168 I default] WaveLab Pro 9.5.20 (build 113)
[2018/03/17 21:49:25] INFO: [     0.360 / 168 I default] Operating System: "Windows 10 (10.0) / 10.0.16299"
[2018/03/17 21:49:25] INFO: [     0.360 / 168 I default] Crash Report Enabled

Here’s my Startup.ini

[General]
Install-ID={24874008-574f-45b0-8ffd-fb092b0acb8a}
RunOnce=true
FactoryTemplates2=true
Launch=80
Project=C:\\Users\\Michal\\AppData\\Roaming\\Steinberg\\WaveLab Pro 9.5\\Cache\\DefProject.wpr
RunOnceOk=true
SettingScope=0
SettingPath=
Language=31
StartupScreen=true
crashReport=true
logging=true
LogRules=
diagExtreme=true
diagCode1=
diagCode2=

Your startup.ini is configured to produce crash reports. Apparently, this does not happen in your case.
What happens exactly when you crash?
Tell me the exact name of a plugin with the problem, so that Steinberg can try to reproduce.

Hi PG,

Here is a short video showing the issue: https://youtu.be/Zc1HKjx9fcU

I have loaded NI’s Solid Bus Comp plugin to master section and pressed the play button. Instead of playback starting I get the error message and after that Wavelab stops responding when I want to remove the plugin, reset the master section or quit Wavelab.

I can reproduce it 100% of the time. Also happens with other compressor plugins from Native Instruments (Vari Comp, VC 2A, VC 76, VC 160, Supercharger, Supercharger GT, Solid Dynamics).

NI EQ and reverb plugins work fine.

When you get a message as the one in your video, that means WaveLab has caught a crash happening inside the plugin code. Please report to NI.

misohoza,

I confirm the issue you report for the NI plugins you mention. Would you be willing to report back here when you get an answer from Native Instruments?

I haven’t reported it to NI yet.

As the plugins work fine in Cubase and other hosts that I’ve tried, their most likely response would be to tell me to contact Steinberg.

Actually, you’d be surprised. Most plugin manufacturers understand that there are differences under-the-hood between various DAWs, even of the same company, and are quite familiar with having to make fixes for WaveLab (or Cubase) individually. In my experience, WaveLab tends to enforce VST specifications a bit more strictly than Cubase (although PG could jump in here and correct me) so perhaps there’s something that’s not quite up-to-specification in these NI plugins. Then again, perhaps these are indeed WaveLab bugs.

I just dealt with such an issue with iZotope, and they gladly incorporated a WaveLab-specific fix. Would you mind making the report to NI? I could, but you’ve obviously studied this particular issue a bit more and have logs/crashdumps ready to go.

Steinberg QA will try to reproduce this issue, and might get in touch with NI too.

Hi,

please try to rescan your plugins with the plugin preference function “Force plugin-Detection at next launch”
Does it help?

Thanks for suggestion. Didn’t help either.

For now I’ve reverted to W 9.5.15 where all plugins work fine.

That’s a very interesting point. PG, did you see this?

Confirmed here also, with SuperCharger GT, which I know used to work fine in WaveLab 9 (haven’t used it in a while). Now crashing immediately on starting playback.

Update: also crashing with another NI plugin, Driver. So probably all NI effect plugins?

I just wondered. Are they VST-2, VST-3, both?

The ones I tried are both VST 2.4 (only) 64-bit (only, i.e. no 32-bit versions installed), both use 32-bit float internal precision, latest versions of everything, and both work fine in Cubase Pro 9.5.20 but crash instantly in WaveLab 9.5.20 with no crash log.

I think it might be related to how the NI plugins report their internal processing precision; e.g. as a test, I copied the wonderful Grungelizer from the Cubase folder into my WaveLab plugins folder, and it works fine, even though it’s also VST 2.4, 64-bit, 32-bit float. I also have a bunch of iZotope VST3’s using 32-bit float precision, no problems there either.

Apart from Supercharger GT, I don’t use any other NI plugins in WaveLab, and I notice Guitar Rig (which is NI’s Fx “framework”) is also on the default ‘ignore’ list in WaveLab, so I can’t test any further.

Philippe was on it: WL 9.5.20 is the version where 64-bit processing was introduced, so that could be an issue with plugs that played nice before (hence his question in the first reply).

The NI plugins are 32-bit precision, but others which are working are also 32-bit precision.

I have tried this and it does not help the NI plugins – they still crash immediately.