NI Komplete S-Series integration gone with 9.0.10 Update

NI Komplete S-Series integration worked perfectly until updating to 9.0.10 from 9.0.1.
Before an own device was created under devices which is gone now.
Also have Cubase 8.5 installed on my Maschine, there it is still working.

Hi,

That’s strange. The opposite should be true. There was an issue in Cubase 9.0.0 and 9.0.1, which was fixed by 9.0.10.

I have the exact same issue.

It is working here on Windows 7 64 bit. I keep forgetting that track focus only works on track instruments. Also the transport is functioning as well. I have saved and recalled several sessions as I was having some issues before . It seems fine now on my machine. If you want to send me a test project I am happy to see what happens on my end.




Hmm…I have had so much trouble with the Komplete Kontrol wrapper for the VSTs that I gave up on it. (in both Ableton and Cubase). I actually just got a Nektar controller to replace my S-25 keyboard. I really like the feel of the keyboard, but it has been too frustrating of a workflow…

I don’t know what problems you had, but for me it worked perfectly before the update to 9.0.10 (also with Live it works pretty well - maybe you had some configuration issues)

My main issue are usability issues. I find Komplete Kontrol to be very clunky and slow as compared to just opening the standard plugins.

Having the same issue with track focus on windows 10 64bit, cubase elements 9 latest update.
The transport controls work along with the main encoder but the last instance of komplete kontrol is displayed on the keyboard and doesn’t change when navigating up and down the tracks.

Sorry cannot help as working perfectly here and has done on the two Pro 9 updates.

Focus was all wrong on 9.0.01 but in 9.0.10 its fully working now… at least on my system.

Solution if it doesn’t work: Enable “DirectMusic” Midi-Devices. If enabled Komplete Kontrol appears as Device and it’s functional again, but the new HotPlug-function from C9 isn’t working anymore.
I think (but can’t test it anymore and don’t want to reinstall C9) with 9.0.1 this was not a problem it also worked with “DirectMusic” Midi-Devices disabled.

Solution if it doesn’t work: Enable “DirectMusic” Midi-Devices. If enabled Komplete Kontrol appears as Device and it’s functional again

Just tried this suggestion and the track focus still doesn’t work :cry:

I’ve just connected a Kontrol to Cubase 9.0.10. This is the first time I’ve connected to any version of Cubase, so I’m not exactly sure how it should be working.

I’m on Win 10 (PC Spec Below). Track focus seems to be working ok on the keyboard - i.e. the keyboard updates when I switch tracks. However, it plays MIDI on any of the Komplete tracks with monitoring enabled. Is this normal? I have to switch monitoring on and off for each track as I navigate. I was expecting the keyboard to only transmit to the selected track.

Update

No, it’s not working properly, it isn’t changing to MIDI mode when I navigate to a normal MIDI track

For me it’s working perfectly.
If it’s not working for you check following kb entry:
https://support.native-instruments.com/hc/de/articles/209557849-Einrichtung-von-Steinberg-Cubase-Nuendo-für-KOMPLETE-KONTROL

And make sure only Komplete Kontrol is enabled under all settings. ext and daw should be hidden and not enabled under all midi-devices.

If all is setup correctly all is working as excepted with the only exception with direct music on Plug’n’play for midi-devices on windows won’t work - BUT Komplete Kontrol works perfectly under Cubase 9.0.1 with direct music disabled!

If it’s not working for you check following kb entry:
https://support.native-instruments.com/ > … TE-KONTROL

And make sure only Komplete Kontrol is enabled under all settings. ext and daw should be hidden and not enabled under all midi-devices.

Tried this and the focus is still not working (Gets stuck on the last Komplete Kontrol instance).

I have raised a support request on both Steinberg and NI so will wait for an answer.

I’ll try the tip above. I’ve put a ticket into NI, so we’ll see what they say. There is a thread on this on the NI forum.

https://www.native-instruments.com/forum/threads/no-track-focus-in-cubase-9.312762/

This was before the latest patch, but NI and Steinberg do seem to communicating on the issue.

There is an update for Komplete Kontrol to v1.8

I’ve installed that, ensured that Komplete Kontrol-EXT and -DAW are removed from ‘All MIDI In’ and activated ‘Direct MIDI’.

Track focus working fine now.

The bug which I have in Cubase 9.0.10 is not directly related to direct music or Windows midi - both are working fine and it doesn’t matter if it’s Komplete Kontrol 1.7 or 1.8.

I have the bug if Komplete Kontrol is added as Windows midi device it’s not stored when closing Cubase, so every restart it’s gone and I have to add it again.
THIS was working perfectly working under Cubase 9.0.1. - please fix this Steinberg!!!