NI Kontakt 7 controls are blocked

I am having an issue with some Kontakt 7 instruments in Cubase. I am unable to use the provided control buttons in the instrument editor UI.
Running Kontakt 7 in the standalone application, everything works. Adding it as an instrument in Cubase prevents the modifier buttons (like ‘sound’ etc.) from being used.

The instrument works. I just can’t edit it.
What am I missing?

I think it’s a bug in Kontakt 7 … turn off FX … does it allow you to edit then?
image

No. It does not.
I also assumed it to be a bug. But on the other hand, most instruments work fine. Only a few do not. So, my hope was there would be a magic checkbox (“Enable Buttons”) somewhere.

I sometimes get this:
image
… but on first loading, I get this:
image
However, the edit controls all respond. What versions of everything are you using?
I’m K7.7.0 on C13.0.20 in Windows 10 22H2, everything latest updates.

Same. Latest of both.
The three dots are weird. I do not recall seeing them. But even the on/off button cannot be used in this one. Strange.

I’m using just stock integrated Intel graphics. Are you using e.g. Nvidia?

I’m K7.7.0 on C13.0.20 in Windows 10 22H2, everything latest updates.

the latest version of Kontakt is 7.7.3

1 Like

Cheers, now on K7.7.3 in C13.0.20, that glitch with the “…” instead of “FX” seems to be gone, controls are still working fine. How about you, @plingpling ?

Same versions here.
I just found out what the problem is: it is indeed a bug.
It works only on the main display. Regardless if external or not. The monitor needs to be selected as “main display” in Windows display settings. I have the mix console and plugins on the external screens.
Could you try, if you can reproduce this behaviour?

BTW: I am using a NVIDIA GeForce RTX 4070 Laptop GPU

… can I ask though, do you feel it’s a bug in Kontakt 7, or in Cubase 13?

I have 2 identical FHD monitors, but I can’t reproduce. Can you do a step-by-step, and I’ll try duplicate?
E.g. start with a blank new project, load K7 (Instrument Track or Rack Instrument?), etc.

Not really sure. I’d guess it is Steinberg’s bug as this works in the standalone versions of K7. Probably wrong mapping of mouse coordinates.

I also have to identical UHD monitors.

  1. Create a new project
  2. Add instrument → Kontakt7
  3. Search for “Bass rounded” (contained in Kontakt Factory Library)
  4. Instrument editor opens

Try to turn any of the knobs/controls when window is on main display
Move window to secondary display and try to use the controls.

In my case it is impossible.

I opened a ticket in my NI account anyway.

Have tried those steps exactly, but can’t reproduce here I’m afraid. The only thing I can think of is to try it in another DAW, even in a trial version of something, just to find out whether the issue is only happening for you in Cubase or not.

Have you tried the Nvidia tweaks listed here: https://helpcenter.steinberg.de/hc/en-us/articles/15279887297298-Graphical-User-Interface-errors-in-Cubase-13

Thanks. Now that I know the problem I can work around it.
Meanwhile I hope there will be an update by Steinberg and/or NI solving this.