No audio after PC wakes from sleep

My UR22c has been working perfectly for almost a year. Now all of the sudden after the Windows 11 PC wakes from sleep, there is no output from the UR22c. It is still recognized by Windows, the DspMixFx app still recognizes it as being attached (but no activity on the meters).

I’ve changed NOTHING on the PC (no hardware changes, no new software). The UR22c firmware and driver were upgraded to the absolute latest some time ago (long before this started).

The only ways I can get audio back are to do one of the following:

  • Reboot the PC
  • Disconnect and reconnect the UR22c
  • Change the sample rate (from anything to anything) using the Steinberg USB Control app.

Using a different USB port doesn’t make a difference. I should note that the UR22c has always, and continues, to be fully powered when the PC is asleep (and the USB/Connected light stays on).
Any theories on whats going on or things to try?

I have no screen saver for just that reason. This article will optimise your computer for recording.
https://www.sweetwater.com/sweetcare/articles/windows-11-pc-optimization-for-recording/

Just a quick follow up to say this is still an issue. Even after a 100% clean install of Windows 11.

Where this was not an issue in the past, I still wish I could solve the mystery. Its super annoying to have to manually reset the steinberg (either by disconnect/reconnect OR changing the sample rate) every time I sit down at the computer (and “don’t ever let the computer sleep” is not a helpful, practical, or responsible solution).

1 Like

Same problem on my Windows 11 machine - have to power cycle my Steinberg UR22C every time. It also tends to hang video playback until the Steinberg has been switched off, which is interesting.

try this, option 2 (disable the computer putting usb devices to sleep when it goes to sleep).

https://www.makeuseof.com/ways-to-disable-usb-selective-suspend-in-windows/#:~:text=Press%20the%20Win%20key%20to,expand%20USB%20selective%20suspend%20setting.