No Audio after Update

Hi Massimo, you don’t need to reinstall the sounds, just download the Dorico installer again and run that. You also don’t need to uninstall via Control Panel. In the Dorico installer, at some stage you can tell it to ‘reinstall’ Dorico, that saves you the step of uninstalling. Also make sure that you let reinstall the components.
If you are unsure, go the long way, uninstall via Control Panel and install again with the Dorico installer.

That option for the Expression Map does not exist for me.

@ThatViolaGuy

When I have this problem, I do the following.

  1. Set Playback Template to ‘Silence’
  2. Save file and EXIT Dorico. And I mean exit completely, not just close the file.
  3. Reopen File in Dorico and set Playback Template back to Noteperformer.

This worked for me for your posted Project. Hope it helps.

Looks like something with your NotePerformer installation went wrong, I can’t help here anymore.
What if you try what Craig proposed?

ThatViolaGuy, I suggest you try running the NotePerformer 3.3.1 installer again, which should make sure that the necessary components are all in the right places.

Hi Ulf, I reistalled Dorico Pro 3.1 the way you suggested, which was quick and with no issues. Unfortunately this did not fix the problem and the Setup Device Form still showed no value for the output ports (with the dropdown menu still inactive), even though the Form showed “Yamaha Steinberg USB ASIO” in the ASIO Driver textbox.
As previously, the only value I was able to change was the sample rate (default 8000), but changing to 41100 had no effect.
At the end I discovered, almost by chance, that the problem could simply fixed as follows:

In my previous tests, I activated the ASIO driver drop down menu, to check if there were other drivers available. The YS USB ASIO was the only one (correct, since no other ASIO driver was installed). However, I NEVER EXPLICITELY CLICKED on the YS USB audio menu entry to select it. As soon as I did it, the sample rate instantly changed from 8000 to 41100 and I was able to see the available UR242 ports in the Output Ports dropdown menu. Also the “Device Control Panel” button worked, opening a tabbed window with the ASIO driver parameters.
Between the two ports proposed by the form for Stereo Output (“UR242 Mix L/R” and “UR242 FX Bus L/R”), only the FX one produced sound: I assume tis is OK and in any case the sound from Dorico came back!

The only remaining issue was that the guitar instrument was played back with a kind of synthesized sound. I believe this is a known (different) issue that I found in “Toubleshooting Playback Issues in Dorico” tutorial by Anthony Hughes, who suggested to fix it using the PLAY->play->Apply Default Playback Template. I believe this was a Dorico 2 command, which is not present any longer in the Dorico 3 (3.0 and 3.1) PLAY->play command menu.
Anyway, this is a separate issue for which I will create a separate post, unless I get a kind comment from you or someone in the Dorico Team.

As far as the no-audio problem, I missed the simple solution because I assumed that Dorico Device Setup should automatically load the only available ASIO Driver, which was found, as shown in the setup form.
In any case any comment from you will be very welcome.
I attach 3 images of the device setup form, with the steps I went through.
Thanks,
Massimo
Dorico 3.1 no audio.jpg
Device Setup Form 3.jpg
Device Setup Form 3.jpg

Ulf, I attached twice the same image: here is the missing one.

No, here is NOT the missing one. Nothing is attached to your post.

It’s getting late here, sorry. File should be attached now
Device Setup step 2.jpg

Hi Massimo,

good to hear that you can now get sound out.
Seems that you’ve found a bug in our software, that, if there is only one sound driver available, it is not properly selected.
I’ll enter this to our bug database and we’ll further investigate.

In regards to the audio ports, that is also unexpected. You should get sound out of any pair of ports that are listed.
What if you choose L/R, close the dialog and reload the current project, does then sound come out via L/R?

And yes, the menu item changed, it is now just called “Playback Template”, so please choose that one instead.

Let me know of any further difficulties.

I have the same/a similar issue. I upgraded to Elements 3 from 2. Audio worked perfectly on 3 … until now. I use Mac CatalinaOS. Instead of Audio output, I now receive these 2 notices:


Screen Shot 2020-01-28 at 10.48.43 AM.png
Can anyone assist? Thanks!
Steve88

The first error is nothing to worry about and can be fixed by going to Play > Playback Templates and re-applying the ‘HSSE (Elements)’ playback template, but this won’t help the second problem, which is that it appears the audio engine is not able to run.

Please make sure you’re definitely running Dorico 3.1, and if not, download the update. Otherwise, please do Help > Create Diagnostic Report and attach the resulting zip file here so we can take a look and see what might be going on.

Thank you, Daniel. I got it to work finally by downloading the update. But still no sound until I toggled “Dorico Beep,” then re-toggled to “HALion Elements SE.” Now the problem is that the timbre of the HALion is not satisfactory. Is that the only timbre available? Can I access sounds that are clearer and not “string-like” in nature? Thanks again. Steve88

Depending on what kind of music you’re writing, you might want to take a look at NotePerformer, which is an inexpensive but very highly-regarded virtual instrument designed specifically for notation software like Dorico. See its website for more information.

Thank you! I will check that. One more thing, please: does the Pro version come with good timbres in playback? More realistic? Steve88

Thanks, Daniel. Does the Pro version come with better playback timbres built-in? Steve88

Pro includes HALion Symphonic Orchestra, which is a step up from HSSE (bundled with Elements). Neither one holds a candle to NotePerformer for most classical score playback (NP is not so great for jazz).

Thanks so much, Dan!

I wonder if you are running into a specific problem here where only the ‘First Contact’ patch gets loaded? HALion Sonic SE does come with a decent quantity of different sounds.

Can you try this? Create a new Solo Piano project, enter some notes and then press play - do you hear a piano or a slow whooshing electronic string sound?

HI Paul. Thanks for this. So, I tried a quartet jazz combo. You’re correct! The timbres are quite acceptable! The only hitch is that I must toggle the HALion Elements SE to “on” each time I make a project. The setting does not “stick” as a default. Is this normal?? Thanks, Steve88