No Audio in from SPDIF Optical


New Cubase user, running Pro 9.5, having a problem getting audio in from SPDIF optical. Environment consists of:

  • iMac
  • Mac OSX Sierra
  • Focusrite Saffire Pro 40
  • MOTU MidiExpress XT USB
  • Cubase Pro 9.5
  • Kurzweil K2500XS
  • Novation Luankey 49

The K2500 is connected to the Saffire Pro 40 via SPDIF Optical, and via MIDI in/out to the MOTU (not that MIDI should matter, right?). In the Focusrite MixControl application, I can see activity on the SPDIF channels when I’m playing the K2500, and audio comes out of my monitors just fine. I cannot get any audio to record from the SPDIF optical connections, however, in Cubase Pro 9.5. I can record just fine in Ableton Live 9 Pro.

In Cubase Pro 9.5 -> Studio -> Studio Setup -> VST Audio System section the Saffire device is listed. When I click on Saffire, I can see latency numbers (Input: 8.707, Output: 7.551). Clock Source is correctly shown as “SPDIF-OPT” and “Externally Clocked” is checked (the K2500 is the master sync source; this is correctly set in MixControl as well). Direct Monitoring is greyed out. Under Ports, in the Input section, I see the following

  • IP 1
  • IP 2
  • IP 3
  • IP 4
  • IP 5
  • IP 6
  • IP 7
  • IP 8
  • ADAT 1
  • ADAT 2
  • ADAT 3
  • ADAT 4
  • ADAT 5
  • ADAT 6
  • ADAT 7
  • ADAT 8
  • LOOP 1
  • LOOP 2

All ports have an 'X" in the “Visible” box. IP 1, IP 2, SPDIF L and SPDIF R are all active. All other Input ports are inactive.

In the Output section, the list from the Input section is repeated, with the addition of the monitor ports at the top:

  • MON 1
  • MON 2

And without the LOOP 1, LOOP 2 ports at the bottom. All Output ports have an 'X" in the Visible checkbox. Only MON 1 and MON 2 ports are active.

In Cubase Pro 9.5 -> Studio -> Audio Connections, I have two Input busses:

  • Stereo In
  • -o Left
    • -o Right
  • Saffire OPT
  • -o Left
    • -o Right

Stereo In -> Left is connected to Audio Device “Saffire” Device Port IP 1
Stereo In -> Right is connected to Audio Device “Saffire” Device Port IP 2
Saffire OPT -> Left is connected to Audio Device “Saffire” Device Port SPDIF L
Saffire OPT -> Right is connected to Audio Device “Saffire” Device Port SPDIF R

I have added an Audio Track named “Audio 01”. In the Track Inspector, input is set to “Saffire OPT” and output is set to “Stereo Out”. The “Record” enable button is lit. No track presets, and I have not touched anything else. I then click on “Record” and get a one bar count in. I play on the K2500, which I can hear through the monitors (thanks, MixControl!). When I finish playing and click on “Stop”, there is no audioform showing in the recorded clip on “Audio 01”. On replay, there is no audio coming from Audio 01. I have tried this a second time with the “Monitor” button active. No difference in outcome.

Again, I have the exact same setup in Ableton Live 9 Pro and can record my K2500 until my heart’s content. Clearly the cabling, computer, devices and instruments are functional. I must have something mis-configured in Cubase. Help?

Today I verified this behavior exists regardless of 32-bit or 64-bit engine setting. For grins and giggles, I booted in to Windows and tried under Cakewalk Sonar Platinum (exact same hardware, exact same cabling). Sonar records audio from SPDIF just fine, same as Ableton. This appears to be limited to Cubase, and limited only to SPDIF optical (the analog inputs record fine).

Worked with Steinberg US support to no avail. They escalated to Germany/engineering and it’s an unknown; suggested working with Focusrite. Probably easier just to recable the keyboard to 1/4" analog. :\ Support was fantastic, however; very friendly and helpful even if there was ultimately no resolution.

I have a similar problem. I have a Scarlett 2nd Gen interface hooked up to my primary Clarett USB via ADAT.

Signal is coming into the Scarlett from my Roland Integra-7.

You can see signal in the Scarlett VU’s and hear audio through the Scarlett headphone jacks but no signal into Cubase through the Clarett ADAT.

All ADAT inputs are recognized by Cubase 10 Pro in my Audio Connections tab.

When record enabled there’s just no audio signal reaching the track… so sad :frowning:

Trouble shot same problem in:
Pro Tools - no issues
Studio One Pro - no issues
Powertracks Pro - no issues.

Has Cubase issued a workaround yet anyone?

Cubase doesnˋt have any issues with recording from ADAT inputs. I have been doing that with different interfaces since SX 3

May I enquirer as to your interface setup?
Which unit is the slave etc?

Interfaces are:
-EMU 1820m, RME Fireface 800, RME Fireface UFX, RME Babyface, RME Digiface USB
Clocked to:
-each other with each being slave and master
-RME Octamic D, RME Octamic 2, Behringer ADA 8000 with each being slave or master, depending on setup
-Yamaha CL / M7CL consoles via MY16AT card with the interfaces being slave

Sorry so long for the reply guys. Been a wee bit under the weather.

So, my Focusrite Clarett USB is my main interface.
My Scarlett 2nd Gen is my second interface. The Scarlett ADAT’s into the Clarett
(Scarlett is ADAT clock Clarett is internal).

Cubase recognizes all the ADAT inputs in the connections page.

I can see the signal making it into the Scarlett.

After assigning the ADAT inputs to a track to record my Roland synth in stereo there is no signal reaching the input monitoring stage of Cubase.
I’ve gone through the Focusrite and Steinberg pages and my PC is completely optimized for audio.

I’d keep pulling out my hair but here’s not much left. :slight_smile:

Windows 10Pro, 64MB RAM, 1TB HD. Tons’ of CPU power!

Do you actually connect the Hardware ADAT ports to the corresponding Cubase busses…?

Yes indeed.

Hi all, any solution? I’v exactly the same problem connecting Scarlett 18i20 with a Behringer 8200 ADA. I can see 8 new Adat Chanels, have signals an the 8200 ADA but no audio signal in Cubase…