No Audio Input Signal in Cubase on OSX Mojave (Solved)

This may have been answered before in the context of a thread, but because the issue is so frustrating, I thought it was worth it’s own post, so hopefully others can find it more easily.

I updated Cubase Pro to 10.0.50 and found that I no longer had any audio input signal, so was unable to monitor or record external sources.
Playback was still fine.
(Using NI Komplete Audio 6 interface)
All my other audio apps could receive audio from the same channels on the Komplete without issue.

I checked and rechecked all audio connection and ASIO settings in Cubase and reinstalled the drivers for my NI Komplete Audio 6 interface.
I trashed my preferences, reinstalled Cubase and still nothing.

I was pretty sure that the issue was with the Cubase update, but checked the support pages on the Native Instruments site too and came across a post about standalone NI apps having the same issue under Mojave.
https://support.native-instruments.com/hc/en-us/articles/360000471958-macOS-10-14-Mojave-Dialog-App-Name-would-like-to-access-the-microphone-

Turns out it wasn’t Cubase or NI, but a security setting in OSX Mojave!
When you first open an app that is capable of recording audio you get a dialogue appear that “X” application would like to access your microphone.
If you select ‘Don’t Allow’ this prevents the application from receiving or recording ANY incoming audio input signal!

I realised that my update to 10.0.50 actually coincided with when I recently upgraded my iMac and reinstalled all of my music software from scratch.
When i reinstalled Cubase I must have chosen the ‘Don’t Allow’ option as I assume my natural response would have been ‘no i definitely won’t be using the internal microphone of the iMAc’ - as I feel this is what the wording heavily suggests.
I feel this is VERY bad UX from apple.

The worst is that there is nothing within the applications of general OSX interface to warn this setting is active or not, so as far a CUbase was concerned, everything was fine.
You literally have to go to System Preferences > Security & Privacy > Privacy > Microphone to fins a list of apps that have microphone access ticked (allowed). and there I found Cubase unticked.
Ticked Cubase and saved.
Hey presto! Now i can record audio again.

Hopefully this will come up in a Goole search for others pulling their hair out at apple’s UX fail.

Hi and welcome,

This appeared in multiple threads here on the forum already.

Btw, it’s not Cubase specific.

Hello zonbizoku,

Thank you for posting this. Our first steps in upgrading our multiple Nuendo systems to v10 and and OS10.14 and I could not get input audio to function. I’ve setup/updated Nuendo systems probably hundreds of times with other versions and was feeling pretty silly.
Interestingly it’s not in the Nuendo manual that I could find, if it’s not perhaps that should be there.
Thanks again,
Hugh