No audio output with Cubase 7.5, ASIO4ALL v2 (Win10)


I’m completely new to Cubase, but my new employer uses it, so now there’s so much new stuff to learn.

At my home office I route my output audio through my RØDE NT-USB, and while I initially couldn’t get audio through that, I installed ASIO4ALL, and my sound came through with no problems. Now that I’m back at my office, I of course don’t use my mic, I just plug my headset into the laptop, but Cubase is now completely mute. It feels like I’ve tried everything; making new busses, fixing VST connections, durdling around in Device Setup, and even changing my driver back to Generic Low Latency Audio Driver (which was default when I started), but nothing.

I have audio from other sources, it’s just Cubase that won’t give me any sound output, neither on my headset or my laptop speakers.


EDIT: I’ve discovered that audio from other sources (YouTube) only works when I have the other driver activated, not whem ASIO4ALL is on.

Hi and welcome to the forum,

Did you adapt the setup in the ASIO4ALL Control Panel? Or did you choose relevant ASIO driver in Cubase.

I did it in Cubase.

What I assume you mean, is that there’s a separate program for setting up A4A, but I can’t seem to find something like that when I search for asio on my laptop, I only find the generic low latency driver setup. (I’m a Mac user on day-to-day basis, so sorry for a certain level of noobiness.)


ASIO4ALL is Windows only. I’m Mac user only. As far as I remember, the ASIO4ALL Control Panel hides it’s icon to the Start/Task bar (or how is it called) on the right side. Like this

Hm. I found the control panel (which was the same as when I open it in Cubase), but that one disappeared when I tried shutting down Cubase, so I think they’re connected, at least in that regard.


You want to use it with Cubase, right? So what is the problem, if it disappears?

I must have misunderstood what you meant! Then the answer is simply “nope, that didn’t work”. :frowning: