No Audio Playback Sound - Elements 12

Downloaded Elements 12 and already frustrated by the software. I have no playback audio sound. I have checked the studio settings (Studio - Audio Connections and Studio - set-up. Both are pointing to the “Generic Low Latency ASIO Driver”, and look correct. But no playback sound is heard.

I am getting notification sounds come through - eg if I try to open a window already open, it presents a bleep, but for the life of me I cannot hear any playback in this application.

I even tried pushing through my Yamaha THR5a amp using the driver for that and same problem.

Clearly I am missing a simple step, but it is frustrating.


You are on Windows, right? We don’t know what Audio Device do you use, but I expect you don’t own dedicated Audio Device with an ASIO driver.

In this case install virtual driver ASIO4ALL, please.

Yep - windows 11. And yes no dedicated device. I’ve just downloaded ASIO4ALL, but it does not appear in the list of drivers in Cubase. Rebooted, tried to download the driver again, but still no luck.


I would try to install the driver as administrator. And maybe I would try to reinstall Cubase as administrator.

I’ve managed to get the driver visible in Cubase. Checked settings, but still no sound. Starting to get really frustrated now.

If I reinstall, do I need to reinstall everything?


No, you don’t. Just Cubase.

SOLVED: After installing new drivers and rebooting etc, I found the solution. And it was a simple one.

Discovered that no output was set for any of the tracks I had added. Switched back to the native “Generic Low Latency ASIO Driver” and enabled the output to the “stereo” bus and I got sound! No idea why this isn’t a default option. Maybe that’s my next challenge :wink: