No bar numbers in system track

This file is a MIDI import from another notation program. Not sure why there are no bar numbers in the system track, as well as it looking quite inaccurate. Also I can’t delete the last bar (trim doesn’t work) and can’t figure out how to NOT split a measure across systems. If you have any clues, I would be very grateful. Thanks!

AAA.dorico (956.3 KB)

I don’t know if this completely fixes the problems you mentioned or just hides them, but here goes.

Select all the time signatures in the piece one at a time and press Delete.
You might have to do some more than once because it looks like they have imported as independent time signatures (ie local to each staff).

Select the first notational element in the music (note or rest), press shift-M, type 4/4 then press Enter.

If you want to re-instate the 2/4 time signature at what is now bar 4, select the first note in that bar, press shift-M, type 2/4 then press Enter.

You might have to re-assign an instrument to each part.

I had a good look at this. I see the problem. All I can say is that it is bizarre. I know that’s not helpful, but at least it is some extra evidence.

The mid bar system break is caused by the bar being too long for the page width. You can fix this in Engrave mode with Format Systems → Move bars to previous system. But there’s something fundamentally wrong with this import. Can you post the MIDI?

I also thought of deleting the time sigs, but why should one have to do this?

It might be that it makes Dorico do some re-calculations to make everything fit in with the redefined “structure”. Perhaps any such re-calculations, coincidentally or by design, deal with whatever caused the initial weirdness.

Part of me screams out in protest if things are not done the “correct” way, while another part of me calmly counters that “Well, if it achieves the desired result, does it matter?”.

What do you mean? What structure?

Thank you! I tried deleting and reassigning the meters as you said, one at a time, and it seemed to have fixed everything, including the extra bar at the end, as well as the spacing across the systems, and the system track. Unfortunately, this will mean a lot of work, as what I posted is only a small fraction of the larger file and there are many meter changes. But at least I know it works! I wonder if somehow the translation of the MIDI into Dorico got corrupted. I will export and import again to see what happens.

However, is there a way for the system track to show the actual bar number? (I want the actual bar 2 to read as bar 1). I know how to do this in the score, but perhaps there is no way to make the system track also show this number, since it appears to simply count measures from the beginning regardless of the assigned measure numbers.

In any event, thank you!

Yes, I agree - why is all this workaround required? I will try re-importing because I think you are correct in that there is something wrong with the import.

After you have reset the time signatures, right-click on a note in the first bar and choose Bar Numbers > Add Bar Number Change… , and set it to zero.

3 bars of 4/4 time. 1 bar of 2/4 time, etc.

When I had deleted all the time signatures and before reinstating them, there was just a stream of notes with no barlines to indicate a pattern of accents, a situation which I would class as being rhythmically undefined or unstructured. Once I had reinstated the time signatures which then divided the first 12 beats of music into 3 bars of 4 beats each, etc., there was a once again a clearly discernible (ie defined) structure (rhythmic pattern/grouping) to the stream of notes.

Others may use different terms for the same purpose.

Other terms such as sonata form, binary form, rondo, etc. have been used to describe layout on a larger scale.

If you have MuseScore (which is a free pseudo-alternative to Sibelius, Finale, Dorico, etc.), you could try importing the MIDI file into that and see what MuseScore makes of it. Then export it from MuseScore (both as MIDI and musicxml) and import the resulting file into Dorico. About the only thing where I find MuseScore useful is for situations such as this where a MIDI file or a musicxml file exhibits some quirky behaviour.

The time signatures in the project attached in the first post in this thread are local, i.e. staff-specific, time signatures, which is why there are no bar numbers in the system track and why the casting off is peculiar. There are no global time signatures, and only global ones contribute to bar numbers in the system track.

The really interesting question is how you ended up with local time signatures in this project in the first place. I don’t believe Dorico will ever create them during MIDI import, so presumably you created them yourself. In general you shouldn’t use local time signatures: they should be reserved only for situations in which they are really needed, i.e. when you actually need different meters in different instruments.

1 Like

Brilliant detective work.

I tried exporting from Sibelius again (both xml and MIDI) and this time it was fine so who knows what happened the first time. I didn’t realize the effects of local versus global, so the local must have been set. In general, should the properties look like this?

Thanks, all!

Screenshot 2023-11-10 at 9.01.45 AM

The middle set of “Show” options is a filter: if it’s set to “Global Only”, you won’t see any local properties in the panel. If the property you’re looking for happens to be local, this will be a problem.

“Should” is subjective: if you want to nudge a dynamic to the left a bit, but only in the part layout without affecting the score, you should “Set local properties” to “Locally”. If you’re changing a hairpin to “cresc…” and want it to appear that way in all layouts, it should be set to “Globally”.

However, in the context of time signatures, the Properties panel scope doesn’t feature: Daniel is talking about the difference between inputting a time signature by confirming the popover with just Return (which inputs a time signature for everyone), vs Alt/Opt-Return, which inputs a time signature only on the selected staff. This is useful if you have a group of players playing all together, but some are in 3/4 and others in 6/8, for example.

Thank you for this clarification! I will now be much more aware of these settings.