[NO BUG]Process tempo is intended for altering playback speed to fit duration

Hi

I have this recording free tempo, kind of, and want to adapt tempo to this.
Thought Process Tempo looked perfect for the job.
48k project.

I spotted one place at 01:01.739=61.739s in and placed right locator there.
Placed left locator at zero in timeline.
Tempo track visible and only one node there at start - I come to different result depending on this value.
This range should be 32 bars long normal 4/4 signature, and want to get bar 33.1.1.0 at the right spot.

And depending the only tempo set, result become very different - and none become right.
I tested with primary as time, secondary as bar+beats and other way round.
Made ruler primary time or bar+beats.

Example setting start tempo 100 bpm as only node existing.
Open process tempo, and change resulting length to 32.0.0.0.
Processing this - values in dialog suddenly changes to 20.2.2.202 length - first node changes to 80.39 bpm.
Tempo scaling before processing says 0.8039 - so it just multiply the node having 100 bpm making it 80.39 bpm.
If you at 100 bpm get 25.2.3.143 at the right locator and want this to be 32 bars even it should increase tempo.

It should divide by 0.8039 scaling and it becomes correct - 124.395???
Then you get 32 bars until that right position.

Or have I’ve gone completely mental here…

It’s a little difficult for me to understand what you’re saying in the narrative style. That said, I find it to be working correctly in a few tests just now.

I’ll test it again - can you do it again and just give the following info?

Since you’re spotting to a time duration let’s start with seconds:

  • Original bpm tempo of region
  • Original length in seconds
  • Desired length in seconds
  • Resulting tempo in seconds

Thanks for comment.

If increasing number of bars into the same time space, number of beats increase and tempo should too.
Now it’s the reverse - tempo is lowered.
And I found if using the scale factor in dialog as presented - and multiply by that - it becomes like Process Tempo do.
But if I divide by the scale factor shown - it becomes as manual calculation tells it should be.

Original tempo can be set to anything - but it is 100 now as I did this test and 4/4 is signature.
Length is 01:01.739s meaning 61.739s. Locators show 00:00:00.0 and 00:01:01.739.
Seconds should stay the same . I want bars to change into the space chosen - new range in dialog is that I increase bars to 32.
Tempo become 80.39 in process tempo and should be 124.395.

128 beats/61.739 seconds=2.073243817 beats per second * 60 = 124.395 bpm.

You have in dialog start at 1.1.1.0 bars+beats.
End at 25.2.3.x(don’t remember exactly)
New range show same as End from start.
You increase New Range to be 33.1.1.0 - length shown become 32.0.0.0.

Pressing Process - you expect End to become 33.1.1.0 as you selected as new range.
And if calculations reverse the scale factor this would be the case.

Instead it recalculate dialog fields to correspond to wrong tempo calculation it did.
You choose new range length to be 32 bars - then that stays as you do process - and other fields as End change.
This makes sense to me, and very useful - if it worked that way.

What dialog in Process Tempo do now - length become 20.2.2.212 when you selected you wanted 32.0.0.0 - that makes no sense to me, not in any context.

If somebody can confirm, please.

Simplest test would be to set locators to 2 bar range, open dialog and say this should be 4 bars - and process. It will adjust previous node to half tempo of now, instead of correct double tempo - now squising in double amount of bars in the same space. Undo works for this operation so easy to do.

You have it backwards though.

e.g.,
I set my real-life metronome to 120, and play two measures in 4/4, it takes 4 seconds.

If I want the same passage to last for 4 measures (in that original tempo), I have to slow the metronome down to 60 bpm.

The number of measures the passage lasts will not change, of course, but the amount of time it takes to perform the passage will double.

Thanks for comment again and for trying to reproduce.
If we talk about midi stuff, what is recorded will play back in half speed in your example - which is not the same tempo in my world.
I understand the concept duration of a musical midi clip is doubled if tempo is half - no problem.

But what is the dialog doing?

Look at Process Tempo dialog and what is says in fields to the right - New Range.

Set locators to 2 bars, and increase to 4 bars as New Range - what do you get?
I get half tempo for 2 bars(node at 3.1.1.0) - playing back half speed from original - no range is changing what I can see.
Playback duration will be altered though.

What this dialog do, my own description:
Process Tempo dialog alter playback speed of a range of bars of musical timebased clips like midi - by altering tempo.
Range will only appear to change - but playback duration changes - due to change in tempo.
If you have a hole to fill - for x bars - you can make midi play during that hole as you extend duration of playback - with this dialog.

So yes, I got it wrong what this dialog was for.
But having this a only button to access in tempo track - seems overrated.

If there were a checkbox, “fit new range of bars to locators” or similar, and do the opposite reversing tempo calculation - it would be an incredible tool to quickly adjust grid to existing audio.

I will edit title bar on topic. Thanks for taking interest. :slight_smile: