No Channel Strip?

After updating to Cubase 7.5 the channel strip won’t show on my input channels. The REV-X is OK but no compressor or EQ. I have not changed the hardware routing.


I am in a middle of a session and I can’t find the channel strip either. (C7.5/Mac) Everything works fine and I get input signal, but I can’t control the channel strip och see any settings. Any ideas?


Rather annoying….

I miss my channel strip…

Open the Hardware section of an input channel (at the top) in the Mix Console. Look carefully at the virtual wiring at the right side of the strip. Notice a little bump on the wiring. Hover over it and it says “Change Insert Effect Configuration.” You can choose the setup you want by clicking on it.

There are three positions, indicated by a black dot in the bump.

The default is at the top, which hides and bypasses the channel FX.

The middle position enables the channel FX to the monitor mix, but bypasses the FX to the channel input.

The bottom position passes the wet signal to the monitor mix and into the channel input.

I hope this helps.

I will look again, but I am quite sure it isn’t there.

I see that you run Cubase under Windows “Nohr” and I are using Macs.

Yes, this is how it worked in previous versions of Cubase, but now it seems like pretty much all the integration for MR816 is gone.

But I’ll have a look again. Thanks.

Thanks for the reply but the “routing knob” is gone. It appears in an old project saved in Cubase 7.0. Guess we`ll have to wait for an update.



It works for me now after consulting the Cubase support.

I reinstalled the latest drivers. That solved problem with the lost Hardware setup panel.

But I still couldn’t find my channel strip. I tried a few different things before I noticed that in the new “Mix Console” has a different way of recalling the channel strip. You new to press the “Racks” button in the top left part of the “Mix Console” and select Hardware and Channel Strip.

Good luck!


The hardware shows up in the mixer but i can´t use the strip(compression/EQ) after updating to 7.5. The REV-X works great. Strange that everything works in a project saved in 7.0 when I open it in 7.5. The hardware routing is exactly the same in the two projects.

I tried to reinstall the MR-tools, but nothing changed.