NO DEVICE - Wavelab El 8 cannot see my new CD/DVD drive

Hi

My old CD/DVD drive died. I bought a brand new Samsung CD/DVD drive. It works fine. First time I’ve run Wavelab Elements 8 it cannot see the drive. I try to burn a previously saved montage and it just says NO DEVICE. I just updated to build 8.0.3 but no difference.

Running Win 7 Pro x64

Device manager reports the drive as: TSST corp CDDVDW SH-224BB. Driver up to date. This device is working properly.


What do I need to do??

Try updating to the latest driver , then reboot:
http://www.gearsoftware.com/support/drivers.php

Hi - Gear doesn’t seem to have anything to do with Samsung. It’s a Samsung drive. Windows reports the drivers are up to date for the optical drive. The drive works fine - I can read and write to it with other software.

It is just Wavelab that will not recognise the drive.

I remember years ago with old Wavelab something about ASAPI filters with Win 2k/XP but I can’t find anything recent about this issue.

I just tried installing GEAR anyway. On restart my system failed to boot properly. Second attempt I got to desktop, checked Wavelab but still NO DEVICE. Now restoring system pre GEAR.

Thanks for your suggestion though.

Any other ideas?

I have no wtried uninstalling Wavelab completely and reinstalling it, but still it cannot see the drive.

I have gone to the TSST website and checked I have the latest firmware for the drive, and I do.
http://www.tsstodd.com/eng/firmware/fwdownload/?functionvalue=view&no=804

I am guessing it is some kind of registry problem. But I don’t know what to do about it.

I have submitted a support ticket but I have not heard anything and I really need to get some masters burned from montages.

Any further suggestions gratefully received…