No el-guitar output on my guitartrack

Hi there, I have a problem recording my el.guitar in cubase 12 pro (the trial version). When I plug in my guitar in my UR22c audio interface I can see input on my meters in cubase and I have sound on my headphones. Only I see no output and when I press record I see no data coming on my track. On the same interface the mic works fine and also my midi controller works. Only the guitar won’t record. What do I do wrong? Do I need to make an extra audio bus or make some route for the guitar?

A picture of your routing could help. I don’t know if you are experienced or not, so I will start with the basic: you must create an audio track and then route the input channel (where your guitar is connected at) to that audio track. You can set up in the audio track the input channel as input. In that audio track you must click on record. If you already did that, I don’t know at the moment what is the issue.

Ok, Im an absolute beginner so it must be a stupid question but how do I route the input channel to the audio guitar track?
Haha, I’m going to start cubase lessons but they won’t start in another two weeks and I am too inpatient to wait that long, I want to play!:upside_down_face::grinning:

Here is the link to manual where the setup is explained…

As it’s an input routing issue :

  1. Go in the Studio > Audio Connections window, then in the Inputs panel. Here, you should have all the busses related to your audio interface inputs. More specifically, you should have the UR22c Input 2 set as connected to the corresponding ASIO driver Device Port. If not, create a mono bus connected to it, with the Add Bus button.

  2. In the audio track supposed to receive the guitar signal, select the corresponding bus in the Input routing dropdown list of the inspector. If I have understood well, it’s an electric guitar directly connected to the input. So, be sure also that the Input 2 - Hi-Z button of your UR22c is enabled, otherwise, you won’t get a lot from it, beside a muffled and almost inaudible sound.

  3. In the MixConsole, check also the Pre Gain setting : if set to minimal, you won’t hear anything…


  1. Press the transport Record , after having enabled record on the involved audio track . You should get something like this, while the recording goes on :

EDIT : added §3…